AMX targeting pod supposed to not lock ground targets?

So new poster here so forgive me if I’m doing it wrong, but I can’t find any info regarding it online. Anyways as the title says: Is the pod simply unable to lock targets or is it supposed to? I tried in test flight and I tried in Ground RB but it’s unable to lock. Other targeting pods such as the Jaguar at 10.3 and the Italian Tornado (I know it’s 11.3 but still,) both can lock ground targets. Is this intentional or is it a bug?

1 Like

It is the same pod as the IDS 1995. I just got the plane, so I dont know much about it.
I suggest you submit a bug report and check the results.

I’m guessing I just need to post a video side by side of the tornado and the amx showing off the bug or do I need some tech doc saying it as well?

No, since it involves the same pod, just show that the tornado can lock onto targets but the AMX one cannot.

alright ill see if i can get one made up btw, you’ll love the amx its fun

One of the two last pieces of puzzle to make Italy 10.3 the best in the br. Just one good AA to go, I guess

Atleast they fixed the thermals of it the non locking makes it so rough especially on colsole trying to keep on target is tough with the joysticks .

I’m just about to submit a report regarding the locking issue. I understand your pain trying to maintain a laser using a controller

Bug report submitted. If you have the same problem feel free to add you have the same issue.

So was looking it up and the a11a had this targeting pod the a11b which is the version we have in game actually had the lightning ll pod it looks like it was already reported and someone has also linked a report on your report

Perhaps we shall see a victory on the horizon