Press M For Map and game crashes to desktop

Okay guys, quick update. I’ve done some digging and apparently AA setting isn’t the issue. At first I’ve been regulary clearing folder “cache” and it didn’t work. So after latest crash today (after not crashing for over 2 weeks) I’ve been digging around files and I’ve done two things:

  1. In your WT folder find app called “launcher.exe”. You gotta right click it → properties → compatibility → and you have 2 checboxes to click: Disable fulscreen optimizations and Run this program as an administrator. Then click Change high DPI settings and at the bottom click checkbox Override high DPI scaling behaviour and select Application righ below it. Do the same in folder win32 and win64 with file aces.exe (allthough changing it in win32 and win64 folder is not necessary from what i see).
  2. There is a folder called "warthunder_yupcache* → delete all its contents (from what i see this folder is automatically deleted after you remove files and start a game but it might be just me)

Okay another thing you can do is:
3. Go to C:\Users*Your_username*\AppData\Local\Temp and delete all it’s contents. (if you can’t delete certain files just press Do this to all current items and SKIP (these files are being used by your PC rn and they are apparently necessary, nevertheless they are really small compared to whole TEMP folder)
Allright then go to C:\Users*Your_username*\AppData\Local\D3DSCache and do literally the same.
4. Open CMD as admin and run four commands:
a) sfc /scannow and wait till it’s finished
b) enter them in that order:

  • DISM /Online /Cleanup-Image /CheckHealth
  • DISM /Online /Cleanup-Image /ScanHealth
  • DISM /Online /Cleanup-Image /RestoreHealth
    and wait till it’s finished.
  1. Paging file can work as well:
    a) type down Advanced system settings
    b) press advanced in top tab
    c) in Performance tab press settings
    d) go to advanced
    e) in Virtual memory tab press Change
    f) deselect top checkbox Automatically manage paging file size fo all drives
    g) Now select C: drive and press Custom size: Depending on your free space, set it around 8000 Initial/Max or 16000 Initial/Max
    -------- If you have warthunder on another drive, select that drive (hopefully it has more free space than your C: drive) and do the same, exept, set Initial to 40’000 and Max to 96’000.
    i) Apply and save.
  2. Using ISLC to clean your standby RAM
    a) download ISLC Intelligent standby list cleaner (ISLC) v1.0.3.2 Released (updated) - Wagnardsoft Forum
    b) On photo you have exact settings
    c) !!! Before you customize settings !!!
  • List size should be approx 1/4th of your total RAM
  • Free memory should be 1/2nd of your total RAM
  • Before you press Start, make sure to click Purge standby list
  • If you start ISLC and you dont see that window, go to “hidden icons” in your taskbar" and press that monitor with “pulse” on it, that opens ISLC. (remember to press “minimize” instead of “close” after you’ve done setup (app works in background and won’t show up on taskbar)
    bcdedit /set useplatformclock true
    bcdedit /set useplatformtick no
    bcdedit /set disabledynamictick no
    Probably 2 of those 3 commands will show error, that’s fine.
    I think I have listed everything that I’ve done here, if I forgot I will simply make another comment.
    Hope it helps guys :)

Quick update (only for windows 10 users, problem doesn’t exist on Windows 11)
What i mean that timer resolution isnt 0.5 1.0 1.5 and so on - it can;t be a number that can’t be divided by 0.5, that’s where 3 commands that i’ve listed can help you.
After you’ve done everything, reboot your PC and voilla - worked for me and for my 3 friends that experienced the same issue on weaker PC’s

That’s some impressive concise work that you’ve carried out to try and get to the bottom of this problem.

Hopefully it will help some others that are experiencing this CTD anomaly.

Can you update this thread with how things are going post work? Be interesting to hear if the CTD’s reappear at some point or not.

Myself, I’ve been CTD free since Jan 1st 2024 - No rhyme or reason, nor did I do anything to remedy. Started WT up and no CTD since then.

1 Like

yeah im playing for over 2h now in different vehicles without restarting the game and no crashes so far

No dice, I’m still crashing at the end of air arcade battles and sometimes when dying.

It hasn’t been happening in air realistic battles for me.

what are your PC specs?

Ryzen 7 5800X, 32GB RAM, RTX 3080 Ti.

It’s not a computer issue, I don’t have problems in any other game, and I also don’t have problems in other game modes–it’s just air arcade.

I’m also of the opinion that it not a PC issue as it the only issue I have with my PC is when playing WT.

Coupled with the fact that for 7 mths I had CTD issues in WT alone and then come Jan 1st not one CTD since - after doing sweet * all to rectify.

If you have Windows 11 DON’T use bcdedit commands!!!
If you did, simply use them again but change every statement from no → yes and from true → false
your system won’t work peoperly

and getting back to you my friend. Make sure to download game from launcher with minimal client (im guessing you’re not playing sim battles because you can’t play sim with minimal client). Then make sure to use exactly the same settings that i’ve posted yesterday, don’t change anything (I’ve copied settings from my friend that seems to work, so I’m not tweaking any settings). If you want to “benchmark” it, take any prop plane to test flight on arcade battles, fly around for a minute, then crash and right after you crash press escape. If you’re not crashing after 3 tries, it’s probably fixed.

I dunno, all those commands you put out really shouldn’t need to be done.

Are you ACTUALLY getting progress, or do you merely think you do as you’re noticing less crashes, which could easily be unrelated considering the fact it’s a random crash much of the time?

1 Like
  • I do play sim, so minimal client isn’t usable for me. I have never seen this crash in sim, although I do play sim in VR, so maybe that’s related.
  • As of today, this is now happening for me in Air RB as well.
  • It still hasn’t happened when I’m using Steam remote play to stream the game to another computer.

Nice observation.

You run the steam client on your local play when it crashes, or the vanilla client from the website?

I run the game through Steam exclusively since I frequently play in VR or via remote play; I’ve never tried the standalone client.

Unexpected to be honest, but very interesting.

I have crashes too since last update.
My AMD Radeon RX 7800 XT crashes and disables itself.
At first it was time to time, now I can barely play 5 minutes in AB naval until it crashes.
I made a brand new install of the graphic drivers, I checked the files of the game and it still crashes.

Did you DDU, or just update/install over the top?

I used DDU and then reinstall.
I just made a Tank Arcade battle and no crash.

1 Like

I turned the game in ULQ graphics and it seems it doesn’t crash anymore.
I guess there is something wrong in high graphics settings.

1 Like

Now this is more information that could be very useful to this thread.