Game has suddenly started with heavy freezes / stuttering

I tried Steam 50GB and 100GB version so HD pack
I tried the gajin launcher with both versions
on both PCs still the same problem

The .22 update completely broke the Mac client. Flying aircraft doesn’t just crash the game, it often forces the entire computer to reboot. It’s a complete mess. Gaijin clearly doesn’t test updates on Mac… it’s a joke.

1 Like

My conclusion is that: It’s only this game that has this problem all my other games work just fine with no issues, therefore it’s a game problem not PC problem.

1 Like

Alright, so NVIDIA guys go to control panel, make sure NVIDIA is set as primary at least for WT. Then fix your FPS, I did 60 so far it works even across the player/bot field modes like Naval and Choppers

I have game freeze issue when ever I press ‘U’ to view my launched missiles. It doesn’t happen 100% of the time, but it does happen every 30 minutes or so. I don’t know what’s causing it and I do try to avoid pressing ‘U’ but it’s an important and very useful feature so its annoying that I can’t use it.

Correct, in fact, I would go as far as too check your GPU usage(mine is roughly around 40-60% avg) and if it’s not peaking to 100% and vram is not maxed out(which in my case it uses about 4gb of vram avg) then there should be no issues in graphics performance.

Other games do not have this issue, I get great FPS on graphically demanding games such as Cyberpunk and stable fps at that too.

1 Like

I have managed to fix it by exiting Vanguard anti-cheat.


nvidia release new drivers try it GeForce Game Ready Driver | 556.12 | Windows 10 64-bit, Windows 11 | NVIDIA

Having the same issue here. After 20 seconds in battle, the sound is constantly cut off and the game lags and freezes leaving me to either kill it from task manager or wait more for a crash. So far tried everything above, even updated my 2070 super drivers to 556.12. It was so sudden, it worked perfectly 4 days ago…

thanks for now - about 20 battles it works

I can only play ground and naval mode, tried air today, but it only works for a short amount of time. Really disappointed, because I like air the most, hopefully this get fixed and if someone knows a solution, please let it know!

same issue here, i can fix the problem by reinstalling NVidia driver, it works ok for 1 hour or so, and starts again laging, impossible to play (tank RB).

When I switched to low graphics, this problem was fixed, so I would say, try it and maybe it fixed this issue

I did that (the file was over 2GB lmao) and it did help, but not entirely. Stutters don’t happen as often now and they mostly aren’t as long. They usually were 2 or more seconds, now the longest seem to be 2 seconds. I also have like 50 more FPS on average. Still I need to find a way to get rid of these completely.

gaijin has acknowledged video issues - it seems they prioritize nvidia and radeon and said they have fixed this.
i would like to see a fix for amd integrated graphics of which they have not addressed.

It works for me thank you.

same issue the game freezes and i get a blackscreen right after then it crashes. happened since the last update

So after testing a few times, I think my stuttering issue was caused by CPU uptime. After 3-4 days, the stuttering started, and got to an unplayable amount around 10 days.

To fix uptime causing the stuttering, try disabling Fast Startup on windows. It’s under Power Settings → Change what the power buttons do. Then restart your computer. You can check Task Manager → Performance → CPU and your uptime should be reset

This may or may not solve your issue, but it did fix mine (whenever I restart my PC)

Adding back to this because it’s still a horrible issue. Running a 7900xt and 7800x3d (24.6.1 drivers), normally getting near 300 fps. Stutters for multiple seconds very often. After tracking my system, I noticed that during a stutter, GPU utilization drops from ~80% to ~15%. Plenty of free ram and CPU performance. Hope this gets fixed

This fixed all my problems!