War Thunder constantly crashing since update

The client has been crashing everytime since last update. My specs are really bad tho but I managed to play with about 50 fps on minimum settings all the time, which I got because of using proton 7.0 for some reason. Now after the latest patch I am able to log into my account and land in the hangar for some seconds, before I get the same error again. The FPS-Indicator outputs my Fps around 40-60.


Hello @EpicFox720,

As you mentioned Proton I’m assuming you are on Linux? If so could you please post your full system information from the inxi -F command?

Also running WT using Proton isn’t supported, I would suggest using the native Linux client as that should work better.

Proton is not officially supported and so we can’t really help with any issues that only affect WT being run under Proton. So unless you switch to the native client there isn’t much we can do as it’s probably a issue with Proton.

Would it be possible for you to upgrade to at least Ubuntu 22.04 LTS? That might help with any issues you are getting.

Also, Your hardware is below the minimum requirements for WT as well.

The problem is that those requirements only work for Windows operating systems. I am using Proton therefore to be able to play. :(

What is the issue you are getting with running the native Linux client?

It is really random where this error occurs. Sometimes in the hangar sometimes when i am about to join a game.

Right, That type of crash mostly happens with GPUs with 2GB or less VRAM, It has already been reported and is a known issue.

Unfortunately with the age of your hardware there isn’t much we can do.

Hey, Man just wanted to let you know it isn’t your hardware. This update broke legit broke something with Proton. I can run the highest settings at avg. 200fps, so it’s certainly not a specs issue. I’m going to see if I can find a workaround Also, the native port is ass.

I also keep crashing. I’m running the native linux client. But I only crash while flying. Either in Air RB or Ground RB in a plane, never while driving a ground vehicle.

inxi -F:

Kernel: 6.3.9-x64v4-xanmod1 x86_64 bits: 64 Desktop: GNOME 42.5
Distro: Ubuntu 22.04.2 LTS (Jammy Jellyfish)
Type: Desktop System: ASUS product: N/A v: N/A serial:
serial: UEFI: American Megatrends v: 4201
date: 04/26/2022
Info: 12-core model: AMD Ryzen 9 5900X bits: 64 type: MT MCP cache:
L2: 6 MiB
Speed (MHz): avg: 4550 min/max: 2200/6087 cores: 1: 4537 2: 4550 3: 4550
4: 4550 5: 4546 6: 4550 7: 4550 8: 4550 9: 4550 10: 4550 11: 4550 12: 4550
13: 4550 14: 4580 15: 4550 16: 4527 17: 4550 18: 4550 19: 4550 20: 4550
21: 4549 22: 4570 23: 4550 24: 4550
Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT / 6800M] driver: amdgpu
v: kernel
Display: x11 server: X.Org v: driver: X: loaded: amdgpu,ati
unloaded: fbdev,modesetting,radeon,vesa gpu: amdgpu resolution:
1: 2560x1440~60Hz 2: 1920x1080~60Hz
OpenGL: renderer: AMD Radeon RX 6700 XT (navi22 LLVM 15.0.7 DRM 3.52
v: 4.6 Mesa 22.2.5-0ubuntu0.1~22.04.3
Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT]
driver: snd_hda_intel
Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
Device-3: Corsair VOID Wireless Gaming Dongle type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound Server-1: ALSA v: k6.3.9-x64v4-xanmod1 running: yes
Sound Server-2: PulseAudio v: 15.99.1 running: yes
Sound Server-3: PipeWire v: 0.3.48 running: yes
Device-1: Realtek RTL8125 2.5GbE driver: r8169
IF: enp4s0 state: down mac: f0:2f:74:32:c2:cf
Device-2: Intel I211 Gigabit Network driver: igb
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: f0:2f:74:32:c2:d2
Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi
IF: wlp6s0 state: down mac: dc:41:a9:ca:bf:2f
Device-1: Intel AX200 Bluetooth type: USB driver: btusb
Report: hciconfig ID: hci0 state: up address: DC:41:A9:CA:BF:33 bt-v: 3.0
Local Storage: total: 6.37 TiB used: 6.79 TiB (106.6%)
ID-1: /dev/nvme0n1 vendor: Kingston model: SNVS2000G size: 1.82 TiB
ID-2: /dev/sda vendor: Seagate model: ST4000DM004-2CV104 size: 3.64 TiB
ID-3: /dev/sdb vendor: Western Digital model: WD10EZEX-00WN4A0
size: 931.51 GiB
ID-1: / size: 1.79 TiB used: 1.29 TiB (72.2%) fs: ext4 dev: /dev/nvme0n1p2
ID-2: /boot/efi size: 511 MiB used: 6.1 MiB (1.2%) fs: vfat
dev: /dev/nvme0n1p1
ID-1: swap-1 type: file size: 2 GiB used: 768 KiB (0.0%) file: /swapfile
System Temperatures: cpu: 37.0 C mobo: 36.0 C gpu: amdgpu temp: 49.0 C
Fan Speeds (RPM): cpu: 0 fan-1: 958 fan-2: 2231 fan-3: 730 fan-4: 909
fan-5: 0 fan-6: 0 fan-7: 0 gpu: amdgpu fan: 0
Processes: 494 Uptime: 1d 15h 2m Memory: 31.26 GiB used: 8.32 GiB (26.6%)
Shell: Bash inxi: 3.3.13

Alright boys I found a workaround. If you have Lutris, download the Windows .EXE from the download page for War Thunder, and run it through wine.

Works perfectly for me. You will need to run a bit to build shaders.

One last thing, make sure to use a virtual desktop in Lutris or it won’t launch right.

Hello @SuperElectric38,

Do you get any error message with the crashes you are getting? If so could you please post the error message you are getting?

On occasion its just “Exception” error with a separate close/restart/send crash report window. Otherwise its a lock-up of the aces process that I have to kill -9 it without any message.

Thanks I am going to try out. Do I need a specific resolution for the virtual desktop?

Well its not working for me man. I get the same error if I run it on wine. I guess I can just wait if it gets fixed.

Right, Have you had a look at your system logs (Xorg, dmesg, etc) to see if there are any error messages at the same time there? Also you could try and delete your “cache” directory in your main “WarThunder” directory and see if that helps.

I can’t see anything relevant in my log files. I sent in another crash report with the ID 8886751a3c.

Right, Did you try deleting your “cache” directory? Also, Are you launching WT through Steam or the launcher directly?

Same problem, starts after last big update. Its same with nvidia 650ti(1gb) and when i buy RX 5700(8gb). I try cache cleaning, steam reset, game redownload (native:not working, proton8:big graphic problems with far away textures, proton7: works until hangar, but crashes after same time). Problem can be related to intel cpu, cause my brother with amd don’t have problems. I have 16gb ram and i even cannot set more than minimum settings because crash.
Proton error like in first post but native drop different in same situation.