Unplayable FPS drops

Since Attila i have been experiencing massive frame drops. This only happens once per session and seems like it happens after a specific amount of time after launching the game.

Usually when I launch the game I go straight into battle and after a couple of minutes my fps will drop from 400 to 40 and then what feels like 1 fps or lower. The game is completely unplayable when this happens and the sounds also glitch out at the same time.

If I stay in the garage and do not play battle. I will experience the same frame drop after what seems like the same amount of time after launching the game so it doesn’t matter if I am in a game or not.

This frame drop will last 30-40 seconds and then will not happen again until my game freezes after it’s been on for a longer while (4+ hours).

I leave the game on as long as possible so I don’t experience this issue every first match.

I haven’t changed any graphics settings since the last time the game worked normally.

My system specs are:

AMD Ryzen 9 7950X
NVIDIA GeForce RTX 4090
Windows 11
64GB Ram

Running the game through steam and yes I did verify the files.


I get the same but my laptop is old

Core i5
8gb ram
Nvidia graphics card

I usually get a freeze before the game loads as well


but i’ve a GTX 1660 AND that was fixed in SONS OF ATTILA update BUT they do a little update of 100Mo that re introdusing this BUG
someone to help ???
Ps: Vsync don’t work


Same here.

Came back form holiday and game shatters like crazy.

i5 13600k, RTX 3080, 32 GB RAM, Win 11, SSD


My God this has been going for the last couple of months, when is this going to be fixed?

1 Like

I just upgraded my pc with new ram, cpu and that stuff

When playing Warthunder exactly what ypu describes happens to me too!

In game: after a while playing, the fps goes from 260- over 400 fps, then it. Drops right down to 80-50-40-20-10-5-2-0 fps… And everything freeze. Cant do anything not even exit to windows, then it suddenly works again, mabye a minute of intense lags then it is back to normal

This is ecpecially in air battles, a little less in ground battles

The strange thing is, this ONLY happens in Warthunder! Other games run just fine!!

I tried limiting the fps but the same issue happened…

There is just no other places to ask for advice on this matter… Many with the same issue but no answers :/

Another data point – the same happens to me with a fairly new system. I do use Radeon Chill to keep my normal FPS at or around 120, but 5-10 minutes into my first game of the session my FPS will drop and sound will start glitching. This usually resolves after around a minute, but it’s consistent in that it happens every time I open the client. Any games after the first of the session will not have this problem.

I’ve deleted my cache for the game, verified game files, DDU’d and reinstalled my graphics drivers, nothing seems to help.

System specs:
Ryzen 7 7800X3D
Radeon 7900 XTX
NVMe main and secondary drives
Windows 11


USE mouse Poling late 125 or 500
dont USE 3.0 usb in mouse
Geforce Exp delt

1 Like

I have the same issue since “Kings of Battle” update. Normally i play on high graphic settings with sufficient fps, now the game drops down to 5 fps so often, that i reduced my settings to low. My game now looks like from the 90s but i still have these massive fps drops. This is not playable for me. I never had this problem in my 10 years of War Thunder


Same issue here. This issue makes the game unplayable for me. Needs fixing ASAP.


same issue here


after last patch i got radom fps Drops from 170fps to 20-30fps, 1-2 times in one round…


Same issue here.


same issue here and high Vram usage on 8GB VRAM (97%)

1 Like

I am having the same problem.

This is a brand new PC.

CPU: AMD 7950X3D
MB: Asus ROG Crosshair X670E Hero
GPU: Asus Strix OC RTX 4090
RAM: 64 GB Corsair 6000MHz CL 30
M.2: 4TB Crucial T700 Gen5 NVMe
OS: Windows 11 10.0.2261 Build 2261

I have had VSync on and off and it makes no difference.


I’ve been getting them so has a friend

Our PC’s are high spec recent builds so not hardware related

Same here

1 Like

Exact same issue ~21 minutes on game clock

Happens once

I don’t know what’s loading but it doesn’t like my system

1 Like

Same, random fps drops, started last week.


same problem here (gpu 4070) all started 3 days ago