Sound mod doesnt work after update

sound mod doesnt work after update ,please help


are you new to modding games?

wait until thr Sound mod has been Updated or install a different one that is up to date

either way it’ll take a while because the Modders have to get used to the new version first

considering my sound mod uses files from the game itself from the current update, its not the fact of it needs to be updated, something is broken/bugged currently preventing them from working.


Thing is, if you’re using a mod AT ALL, and you’re finding it breaks inter-patch, then it’s not the game, but the mods fault and you’ll have to remove it and check that vanilla works, then hope the actual mod creator fixes it when they figure out what’s wrong with it.

I am using sound files from the current update. read the message fully

to provide more clarity if you need it, I’m using specifically the JP files. and its worked fine in the past with every major update and now it does not. so either its bugged, JP sound files are at fault, or a weird 3rd thing. regardless all the assets use come from gaijin themselves so this is on them

But if it’s a mod you are using…

Think about this… I have read what you put, and you self-declared that you’re using a mod… It doesn’t matter if it’s using the current sound files from this update, the mod is B R O K E N… So clear it out, and wait for it to be fixed.

It’s not the games fault.

do you know how sound mods work? you make a folder called mods, enable them in the game config. and put the replacement sound files into the mod folder (AND TO STATE AGAIN, IM USING FILES FROM THE CURRENT UPDATE IN THE MOD FOLDER). it is absolutely the games fault because its never broke like this in previous major updates and should have attention brought to it

And they broke this update obviously… Just because they’ve worked prior, doesn’t mean they’ll work all the time…

This is how mods work, and when updates happen, the game isn’t the problem…

Clear out the config, clean up the folders, and wait for them to actually fix the mod.

The files come from the game, directly from the language pack every installation war thunder has. The game doesn’t seem to be using the files, which I will reiterate again i grabbed from the current update version of the War Thunder installation sound folder, and edited the file name accordingly to work with my language. so if that is not working then Gaijin themselves have accidentally broke something in the config.blk to not read from the sound mod folder. so Gaijin needs to fix this. I’m not about to assume that you know nothing on this topic, but you are showing to be very frustrating discussing this issue with. Especially the “clear out the config” statement considering if you do that you’ll default your game settings.

Have you even tried deleteing and letting the config file recreate, and readding the lines you add?

Because if you haven’t then that’s a you issue to be real, and expecting it to just always work is ignorant.

Yes I’ve tried, I wouldn’t speak unless I was without an answer after exhausting all possible options from my end. swapped the game to the language I’m pulling the files from (with the mod disabled) so the files themselves are not the issue. So again, Gaijin needs to look into their own Config.blk and figure out why the enable sound mods code is not working

You didn’t say you had so I wouldn’t assume that you had on that note, hence why I ended up asking.

Weirdly tho, only the crew and quick chat sound mods don’t seem to work. I created my own Halloween theme for the main menu, and it’s still working fine. My guess is that they intentionally made sound mods for crews and quick chat not work for some reason

Typically sound mods don’t break. Audio sound mods do, but if the said file is not changed per major and or pseudo-major(cough fire, and ice cough) updates it doesn’t. Voice mods which are also Sound mods shouldn’t break since Gaijin typically doesn’t update their voices.

I can confirm what @YepIndeed is saying.
I am also using the games audio files for crew voices and it doesn’t work.

Before the patch I made a post on Reddit, explaining how to do this and now it no longer works. Gaijin must’ve either disabled this or borked something in the patch.

You can read the guide and that should, without any possibility of misunderstanding, tell you that this isn’t a mod problem or a user error or what ever else layer 8 issue you want to find here.

Can confirm that voice mods are no longer working. Tested with multiple sound mods and also tried replacing the files in the “sound” folder with no successes.

They don’t disable them, voice mods just get screwed over when Gaijin adds more voice lines and such.

1 Like

I tried replacing the files in “sound” with mod files with game fully launched ,and it work.

Sound mods=work. Voice mods do not at the moment.

1 Like