Radar missle seeker not powering on even with lock

Whenever I try to use my radar missles i use my Weapon lock (air to air) keybind to spool up and then fire with the Fire secondary weapon keybind but today the missle seeker stopped even powering on. Ive tried restarting my console as i play on xbox as well as making sure none of my keybinds clash. The link attached is an xbox clip of what is happening.
(ON1YA1M |  Xbox)


IR Seekers as well?

Also try deleting the loadout and remaking it. Sometimes updates break custom loadouts, no idea why

I’m having the same issue… I just unlocked the Mig 29, and am not familiar with in game controls and tendencies… but I am getting a radar lock, but when I get to the missile spooling up, the reticle instantly disappears, i’ve tried in all modes, and changed within visual range mode too… nothings working. Any versed players having these same issues?

1 Like

This is a very long-standing bug, happens with all of the spin-up missiles. lmk if anyone knows a fix other than spamming the lock/fire button


I have had this issue with IR missiles. Sometimes I have to reactivate them.

im having same problem and it started today I cant use Sparrows on F-16C I know why would u need sparrow when 9M is so good but I do like having SARH’s and that all aspect PD was real nice to use

is this a common way to get past the bug? I would just like to use what I’ve been grinding for… R60Ms just won’t do it for me at 12.0 BR. At this point it’s more efficient to play around 10.3…

Yeah, but it’s hit and miss. Sometimes it takes 1 retry, sometimes it takes 5+

Rly fun on the earlier sidewinders that take a billion years to spool, then having to retry 5 times in the middle of a dogfight.

1 Like

same problem, I block with a TWS, but when I activate the search for the missile the radar freezes and does not respond to any command, and I cannot lock on anything or change mode

I found that i can still get kills as normal with the ir missiles just the r24r and aim 7f i tried were bugged

The workaround for me was to use Weapon lock (air to air) for a consistent spool up instead of having to retry 8 times and then fire as normal

right… but why use the same missiles available at 11.0, in 12.0… I was getting more RP and SL from playing 23M, and 21bis… maybe i just need to get used to it, but it seems unplayable if you’re not done with stock grind.

same here cant use radar missles in any plane anymore since today all my friends on xbox cant either its def a bug or glitch please fix this

I second this, and also play on xbox, the R24T’s work fine, but the R24R’s do not.

you cant lock a missile with TWS they removed that for some unknown reason.