KEY MAPPING ERROR (Shift+C conflict and many other!) NEW (FIXED)

See screen shot

If i press “C” i can’t press shift now

And if i press “Shift” and then “C”, “Shift” will be canceled

I had key mapped like this since 2014 and it always worked, i’m unable to play game, please fix that.

I have all possible keys already binded, i can not change “C” into “X” or “V” even if that fixes the issue, i tested it.

Same bug reports, Key Mapping is completely broken for many more keys combinations than just Shift +


Wanted to play war thunder, and i can’t.

And i did restated whole pc + checked keyboard settings before reporting, so it’s not my hardware issue

  • Grass is still flickering on TAA setting, it does that rapidly.

I feel nothing but pain, on build it still worked fine… just why

Just 3 days ago, windows 7 was not working, and here, 3 days later, key mapping is broken

You get back late, wana play a game or two = denied.

I fly 90% on key board, all maneuvers i do this way, and i did it since the dawn of war thunder release, i just can’t play game without it, and it never was broken before.

To explain better i have free look camera on “c” and positive g elevator on “shift” and now those two can’t be pressed together, but negative g elevator “caps lock” still works.

Pain, just pain, and god knows when they will fix this, as this is nowhere as mainstream as windows 7 not working

Not only i have keys binded to every possible function in “wsad” region, i have years of habit built into my hand, i beg you fix this fast.

1 Like

Reason found

Gajin made “great” addition of forcibly adding keybinds. You had saved prests of you keybinds? jokes on you, they got overwritten.

Fix new dumb keybinds that overlap with your original keybinds and everythink works fine

Thanks mate! I was going absolutely mad with non working keys. Redoing most of the keybindings did the trick.

1 Like

It doesn’t work for me. I also use C to look around me and shift/ctrl for throttle increase or decrease but I can’t press C and Shift together at the same time which is pretty annoying. Because there are many situations where you want to use these keys together.

Like why should we be redoing all our binds? there are so many keybinds to use with Mouse + Keyboard in Air RB… Hell I don’t even remember all of them from top of my head.

When do you guys think Gaijin will fix this themselves? I just like to use my config and update it once in a while if it needs adjusting and in case of needing to reinstall the game or something I just import config from a file.

Gajin forcibly added new key binds on top of ours, so there is a conflict of two functions using same keybinds. Open steering and remove gajins additions.

Then shift+c work again

1 Like

I have the same issue and want to try your solution.
What keybinds are the ones i have to remove though?

Thanks in advance

it was some guided bomb sight? shift+space it was binded (i think it was bomb sight, scroll thru air planes settings and look for stuff starting with shift+)
And then remove it, and then add key for it or just forget it ever existed until you will need it one day

1 Like

Thank you very much :)