Ground quality issues

If i have ground quality slider set above half i always experience micro stuttering in air battles, no matter all the other graphics settings. Fps counter shows like 70-80 fps, but you can clearly see jumping between frames.

Some maps are free of this only on the lowest setting, for example spain or zhengzhou.

It also applies to some ground maps, the most extreme example is tunisia.

It wouldn’t be such a problem, since i can’t see the difference in quality anyway, but i see unloaded (very poor quality) terrain consistenly on some maps. It looks like the game thinks area around my plane is off-screen and doesn’t load the terrain there, it only loads when it is at the center of my screen.
(when playing tanks terrain loads normally)

My setup is:
i5 12400
ram ddr4 2x8gb 3200mhz (cl16 i think)
msi rtx 3050 gaming x
1440p 144hz monitor with gsync compatible

I play in 4k with dlss on performance and uhq textures, everything on max except that damn ground quality, my vram usage is 7gb even with ground quality on max too, so there is 1gb of spare.

Any solutions? I know it’s not exactly the best category for this, but i got no replies for over a week in the proper category.

Issue that you describe, including missing textures, feels like either 1) you’re out of VRAM or RAM (yes normal RAM) 2) your system isn’t able to load the textures fast enough (some bottleneck between CPU, Storage, RAM, GPU).

Whatever is displayed on your screen, has to be prepped by the rest of your system (this is handled by CPU, and loaded in RAM from storage). Microstutters can happen when GPU is waiting for rest of the system to catch up. Rest of the system can be busy doing any number of background tasks, or simply not fast enough. If microstutters go away when you reduce texture quality, then feels to me like there’s a bottleneck there due to texture size.

You can try set stuff in nvidia control panel up to max performance, maybe it helps, I’m not sure.
image
image
image

Maybe also don’t play on DLSS, and just use native resolution instead of 4K. I’m not sure if it tries to load textures at 4K before it runs through DLSS.

It may be that rtx 3050’s poor memory bandwidth shows. Cpu usage is rarely above 60%, mostly 40%, while ram usage is around 10gb. I said vram usage is 7gb, but that’s on the ground, in the air it depends, but around 6gb. I personally think it’s a game software + memory bandwith issue. When ground quality is set to half, my pc has no problem with loading textures once they are on the center of the screen, it just doesn’t do it when it should. Also on a ground tunisia map even when i have everything at minimum except ground quality, when i shake the camera on the spawn fps counter can go as low as 40fps and 1% low fps is like 30, which clearly indicates there’s something wrong with optimization. On tunisia all the problems go away only if you set ground quality to the minimum.

I have already optimized nvidia control panel long time ago, i have changed things there MANY times.

I’m playing in 4k with dlss because i can’t stand war thunder’s normal taa, it’s absolutely terrible. Just dlss is not grainy, but still blurry, so i’m upscaling to 4k. Maybe i’m exaggerating, but in a game like war thunder with huge distances and no spotting mechanics bad antialiasing really pops out. I don’t use dldsr because it conflicts with dlss, both use the same tensor cores.

Edit 1: The only thing that runs at 100% is gpu core. I don’t know if memory bandwith counts as gpu core.
Edit 2: When i said normal taa is absolutely terrible i meant ground battles, in the air it’s not bad at all, but i’m not gonna restart the game every time i want to play a plane to change resolution.

If vsync is off or youre not hitting your monitor’s refresh rate your GPU should be 100% utilized, so that’s normal. It could be your GPU’s memory bandwidth, limitations really start to show there at higher resolutions/large textures. Guess you’ll be stuck at lower res textures… I haven’t checked what memory bandwidth it has, but checked it now and 128 bit isn’t a whole lot… :\

And yes, WT can have some odd issues with FPS stability, though considering the amount of assets on the screen at times, they do a reasonable job. It might simply be their game engine getting a bit dated again

I have tested playing with 3413 x 1920 resolution (x1.78). I get 110 fps while zoomed in at enemy bombing points, but when i move the camera i can see them jumping, maybe a bit less, but it sure doesn’t look like 110fps. Overall i can feel 110fps, but when i look closely it’s not true 110fps. This is very odd and annoying.

Edit: Just an rtx 3060 could solve the problem i think, 360GB/s vs 224GB/s bandwidth.

Actually it may be just a game software issue. When playing at 1920p with fps capped at 85 (using riva tuner) i get perfectly smooth frametime graph, but i still see jumping between frames when at max ground quality. When i switch to ground quality at half jumping disappears.

Looks like some work on the game engine is needed.

Edit: It also explains terrain loading issues.

Reinstalling gpu drivers solved the issue almost completely when playing at 1920p (dsr x1.78). Every aerial map works fine with ground quality at half. I’m getting around 120 fps in the air and 90-100 fps on the ground. Only zhengzhou has texture loading issues, but i blame that on the game. It improved even for ground tunisia, where the problem was the most severe, still better to set ground quality to the minimum for silky smooth fps, but it’s much much better than before.

Not long ago i was reinstalling gpu drivers after every war thunder update, but i’ve never seen that big of an improvement. Maybe i should clean install every gpu driver update.

I will still look for rtx 3060 or rtx 3060 ti though.

You should always use DDU when reinstalling GPU drivers and set everything up fresh, it will solve a lot of issues and isn’t much of a hassle to do once you’re used to it

1 Like

Please upload a current dxdiag.txt log to your post.

There are some key issues I can see with your setup and the settings you’re using though.

The RTX 3050 is generally only good for gaming at 1080p. A lot of that has to do with limited memory bandwidth, being on a 128-bit bus with only 14Gbps memory. The other part of that has to do with it only using 8 PCIe lanes instead of the full 16. Not really an issue at 1080p, but when you start pushing higher res textures at 1440p and 4k, it’s going to be hitting those bandwidth limits. Not to mention, if you’re using UHQ texture settings in the launcher, those textures are 4k or 8k resolution. This means loading/unloading to swap out those textures takes a lot of bandwidth. This is why you see textures not loading properly around the screen edges or outside of the center of your screen. Your video card quite literally can’t keep up.

However, you’re completely defeating the purpose of using said UHQ textures, by using DLSS Performance mode… As that would be rendering internally at 1080p, and outputting at 2160p. You may actually be better off playing at 1440p with DLSS quality preset. Or stepping down to the standard texture pack until you can get a more powerful video card.

You may also want to check to see if your PCIe slot your video card is in, is set to gen 3 or gen 4 in the bios. With that GPU being limited to 8 lanes, that could have a major impact on bandwidth if not set correctly.

I don’t think loading issues exist because my gpu can’t keep up, they only appear when i reduce ground quality. At max ground quality there are no loading issues, only frametime consistency issues.

Textures don’t seem to be affected by dlss, i see no difference with dlss on or off. UHQ textures are important to me, because without them planes look kinda bad.

1440p with dlss quality is much worse than 4k with dlss performance. At 1440p it all looks fine as long as you don’t move the camera. Then dlss introduces a lot of blur, while standard taa is just overall grainy and has same performance as 4k dlss performance. I bought a 144hz monitor so it won’t limit my gpu and chose 1440p because i knew i would be playing war thunder at 4k anyway and other games i play aren’t as demanding.

It was set to auto, i set it to gen 4 and nothing changed.

Edit: Now i see there is a difference in textures with dlss on vs off, but from far away. To me textures look fine from far away with or without UHQ textures, but they look not the best when sitting in the cockpit or just zooming in, that’s why i use UHQ textures.

Hello,

Sorry for bumping this old topic, but as someone who has a lot of issues with micro-stutters that makes the game feel bad to play, i’d like to post some of my findings here in case someone has the same issue :

My specs are the following :

Cpu : I7-9700
Gpu : RTX 2080 Ti
Ram : 32GB 3200MT
Game is on a NVME SSD
OS is Windows 11

1st thing :
Dropping the settings don’t change anything. The FPS increases, but the frametimes are still as inconsistent.

2nd thing :
It is NOT operating system dependent. As i am considering switching to linux, i installed linux on another drive. I tried war thunder among other things and the game still had the same frametime issues as my terribly bloated Windows install. So, any driver config, os config or anything of the sort will help. If an entirely different OS/driver install has those issues, then the problem not coming from there.

So from there the only culprit seems to either be the Hardware, or the game

Although my cpu is starting to show its age (5yo now), i see people playing this game with 5th gen I5s and way worse gpus without issues. So i’m fairly confident that my hardware can keep up with the game. So the only culprit left is the game.

As such, those issue are caused either by

A: An overall issue with dagor engine
B: One specific setting that is bugged. Wich is the option I think is the most likely. I’m currently trying to find that setting in question.

Try reducing ground quality, half of the slider looks pretty much identical to the max setting in ground battles and freed me of this issue on rtx 3050, only in air battles you will probably see some map squares on the edge of the screen not loading in, as if the game thinks they are off-screen.

Edit: Unless you already tried it. Now when I’m looking at what was this thread about, it would be weird if you missed that.

Other options that eat performance are effects resolution on very high, global illumination quality and shadows.