Frame rate drop

getting random frame drop since update, my fps goes from 130 to 13 for like 3 to 5 secs multiple times every match. i check my CPU, ram, gpu and thermal all of them have room left, and i didn’t change any graphic settings recently on the game


I have the same problem.

1 Like

me 2.

1 Like

when is this going to be fixed? I see a lot of this online by other players as well.

is it like this? i have this issue

If you record to your same drive as the game and your OS is on this could be something…

And if anyone else that is having this instance is running shadowplay, with the ‘auto clip’ on events, or the ‘clip’ option to catch the past 30seconds or so with the same situation (Same drive with OS, game and video cache on it) that could make it worse.

I am using nvidia experience, i have tried to “turn it off” and such with the issue still being there

Nvidia experience should not cause this issue, even tough it suddenly for some reason the last year has been full of bugs like keybinds not working, mouse being extremely slow whilst browsing in the experience menu… But i used it for 1 year wirhout any problems at all tough with all functions

I did an clean install on a new ssd as well so everything should have worked properly…

Shadowplay, recording to the same drive, will cause extreme problems such as what you are demonstrating lol…

Disable highlights, and instant replay.

The second drive is a good idea, third is even better.

I run OS on one set, Game on another and have another cache drive for my video.

I have tried turning all of that off as well but nothing works lol. Also when i have used nvidia experience, the overlay lags, mouse too fast or to slow, and when i quit i cant press certain buttons without returning to windows screen, and sometimes the alt button somehow gets stuck and i cant use any functions xd

I have os on the upper m.2 slot, games on 2nd and pictures videos etc on the 3rd m.2

Prefer to have the os m.2 ssd as clean as possible :)

I guess it is a most cause, mabye sell ang make an entirely new pc, clean start…

Gone over some things now and they did not work

So far i know this happens once per battle, air, ground naval and others (not hangar) after 30-60 secounds

it then goes on for 1-2 minute before it suddenly stops and everything is fine again!

this is again the only game with this issue, other games such as FS19, PUBG, bean ng, gta… has had no issues so far

I think it’s their anticheat that causes problems


What can be done about that

you can turn it off but you can only play air

otherwise I don’t know what to do

1 Like

I play everything xd

It has always worked tough

What GPU do you use?

There is some kind of memory allocation issue for years now.

It seems to affect 6-8GB cards, but not bellow.
The issue is basically that the game wants to allocate 8.5-10GB vram, and it causes some weird issues with 6-8gb cards, but somehow not with the bellow 6GB cards.
It is very weird, and only a small part of the playerbase gets it.

I experienced the same with my GTX 1070 laptop. It was not overheating, CPU/GPU was hanging at 20% use, but the VRAM was maxed out.
Tho it only caused frame drops minimally, it caused more like stutters.

Now i have a comparable GPU (Tesla M40, basically a Maxwell Titan X, but for datacentre), and a Xeon CPU (core per core weaker than the laptop CPU) with slower RAM, and the issue went away.

I have talked to people with 3080Ti having the same issue.

1 Like

Gainward Phantom RTX 3080 10gb

But due to its functions etc i can almost suspect it is faulty, even tough it works fine in all other games, i think i’ll just sell it if it sells and get a new 4080 or something xd

That last post is even mentioning some of the usual points. There was a period where the 2080s were having trouble when they first came out.

go buy the new 70eur ship pack. this is fix your problem (gaijin logic)

1 Like

Well i was sometimes 10.5-11GB allocation too, so maybe you can try MSI afterburner and check it.

Also what’s funny, this had a dedicated topic, but the mods just removed it…

What was the title of the thread? The ones I’ve been on haven’t been deleted…