Fix for this artifacting and screen tearing?

GPU is 100 percent fine and this only happens in WT.

1 Like

When this happens check windows updates + optional updates. Ensure that GPU drivers are up to date as well.

I have noticed that a lot of WT goes through DWM and if something is out of date / incompatible it causes major issues.


Personally I have gone as far as frame limiting WT as well as I have noticed that in some cases it tries to infinitely render, also causing problems. After frame limiting 99% of the problems went away as long as everything is up to date.

I have :

32GB 3200Hz RAM
Forced FPS limit to 100 @ Movie Quality

Sorry for my ignorance. But how can I limit my FPS? and what is your suggestion for me?
My specs i5-11500
16 gig ram
Gtx 3050

Play a better game?
Its just a fact o life of the Dagnor Engine. There is a reason they give it away for free. lol.

Are you using Vsync (or adaptive vsync) ?

One way you can frame limit WarThunder is by using the Nvidia control panel (should be in your start menu somewhere). In Manage 3D settings there is a Max Frame Rate setting. Note that this is all 3D stuff (including other games) so you’ll need to change the setting back for other games if you don’t want to limit them as well.

Dumb statement? Dagor engine isn’t for free, its proprietary to Gaijin. A lot of game engines are actually free to use, just not free to commercialize … Unity, CryEngine, Unreal Engine, given your statement, being free = bad, those are all bad engines?

Issue OP is having seems more driver related, maybe specific settings in WT graphics around Particles

Turn up the gain on your sense of humor.

Yes, your comment is hilarious.

Thanks for reminding me, I noticed my V-sync wasn’t working for my game.

nVidia control panel > Manage 3D Settings > Program Settings > Select a Porgram = War Thunder (aces.exe)

If you currently get above 100 FPS I would suggest limiting it to a 100. Be sure that the application is closed when you limit it. Play around till you do not see screen taring. Do not use vsync cause it is a buggy mess.

1 Like