Dev server broken?

I can get in just fine, but any of the UI is just broken :/

1 Like

What I’ve tried:
-Restart computer
-Restart game
-Reinstall game
-Reinstall launcher AND game
-Run on windowed
-Waiting like an hour
-Run on lower graphics

Its the dev server. It does that while they are futzing with it. Just wait until you see another patch or file update load.

At first i thought that but then i see that there are some people on it, and i doubt they’ve been nonstop messing with the game over the past 4 hours

d/ling it now… let you know in 5.6GBs.

Was there some kind of new thing where your profile gets reset on dev? It has me on level 4 with nothing unlocked except pack vehicles…

not to my knowledge, even though i cant use the ui all my stuff was still there

It worked fine for me. sorry.

ive got the exact same issue, if you manage to fix it mind telling me how, thx

Ill make sure to try and remember to tell ya, feels better to at least know its not just me

1 Like

I am having a very similar issue. Made a thread on it. Really sucks lmao.

I’m having the same issue, I have tried everything you listed to no avail, I even tried launching the game in administrator mode, still nothing

I just tried turning the dev server easy-anti cheat off in the launcher after lauching as administrator and it seems to work now

After the “problems” last update, I installed the Dev client on a completely different drive than the regular WT game. I donno why that would make the UI stop responding. But…

Hey turn on auto login on the login page with anti cheat off. Seems to work for me

I turned off anti cheat but cannot turn off auto login since I turned it on. Have any ideas on how to turn it off?

From your player card page click “switch users” and it will give you the option to deselect autologin.

1 Like

My mouse worked just long enough for me to turn it off and try to re-login but no-go.

I have no clue, is there anyway we can get a tec mod on this? I honestly do not know what else to try :/

Well, i got through 2 matches and it broke again. Honestly dev server is fun but it aint worth this

1 Like

So you turned off the anti-cheat in the launcher as suggested above?