"Could not unpack some files" error

Hi, I am a long time player of war thunder and I have been hit with a bug I was told to ask a dev about it the bug basically says “Could not unpack files. This can happen when there is already a file with such name in the directory and it could not be removed” I’ve searched the web looking through forums after forums looking for a solution but I have yet to find one if you could please help (and usually after I press ok it brings me to “Download Lost or Updated Files”) this is my 2nd time asking and it has yet to be resolved

1 Like

Uninstall and reinstall.

I’ve tried that

Have you tried completely deleting the entire directory for Warthunder and Warthunder DEV (Dev server) after the uninstall to make sure all files are gone and reinstalling it?


Do you have multiple drives that you could install Warthunder on or just a single hard drive?

I keep my games and work on separate drives

and incase your wondering I’ve done everything I can I’ve searched all over the web for a solution yet to find on

If you use onedrive, I know that can mess about with crap, but also make sure you exempt the game folder from windows defender and any antivirus you have.

I don’t use one drive the only time I use factory reset is when I have to in order to fix my pc but I still don’t use one drive

Didn’t mention windows defender or your antivirus.

Be sure to install to a new folder too considering the error message is saying about file access, whioch could even be something to fire up the launcher as admin.

I’ve also tried that before from an older forum post

Try uninstalling with Revo Uninstaller (Get it from ninite.com) and then reinstall

Launch revo and click on War thunder, it launches the normal uninstaller and then brings you back to revo, select ALL the files it finds (files/registry entries, etc) and click “Delete” - then reinstall.

Can’t find it…


This is my first topic I’ve messaged a dev about it because a friend of mine told me

Just tried and no

I also want to make sure you know I use client side not steam.

Can you upload an error log?

or have them converted

Sorry I forgot to edit my Username out of the logs so I don’t dox myself
2024_05_14_09_13_11_10516.blk (2.2 MB)

2024_05_14_09_13_12_8132.blk (3.2 KB)