After playing on the dev-server coming back to the production servers, my EasyAntiCheat has been having some technical difficulties


No matter what I do, it keeps popping up this tab that force closes my game if i X off of it. I’ve tried restarting my Game, Repairing EAC itself, Restarting my computer but nothing seems to work.

Having the same issue.

1 Like

Have you guys found a fix

Be sure that the ‘everything’ you do is actually what’s recommended.

You NEED to run the EAC setup AS ADMIN.

But anyways, so what have you actually tried here? And did you install it to another folder rather than your game folder…

Ran EAC setup as ADMIN, did repair, uninstall, and reinstall.
checked services.msc and that is set to manual.
unchecked enable EAC close client - rechecked EAC closed client
logged back into dev server and game runs fine
tried live server again same issue

Assualts and air seem to work but ground and naval crashes.

Here’s a bug report on the matter. Go press “I have the same issue.” if you’re experiencing errors. Add your own evidence in a comment but don’t spam the comments.

And this one in Engrish too! Spam SPAM spamity spam. Gaijin fix your game.

Gotta be sure though as to what’s really happened to be sure.

One of the biggest advices to using the dev server install is to use a seperate game folder rather than your actual game folder.

And the ‘everything’ everyone talks about in these threads is so vague that it forgos the initial ‘verifying files’ advice.

No its still an issue because the game defaults to installing dev into the same directory, and it produces the error even if you have separate installs.

i mean i tried to look for “run as admin” but couldn’t find it so i just ran it, and
pressed “fix service”

yeah, The dev server is the only thing working for me rn

I’m uninstalling both and reinstalling only the regular client.

This same exact thing happened to me too, I installed the dev server went back to the production and the same error message pops up. I’ve also restarted the game, repaired the EAC, and even uninstalled war thunder and re-installed it and nothing worked.

Spoiler!!! /jk

Right click the exe, run as administrator… If you don’t it won’t have any actual access and won’t be able to make changes.

This is another situation that antivirus exceptions are also wise to put in place for the game folder.

now this popped up on the dev server

1 Like

That usually comes up when antivirus is meddling with the install when I’ve seen that pop up.

its still because the anti-cheat is bugged