Unable to Access Account After Multiple Password Resets

I’m reaching out in hopes of getting some assistance with a serious issue I’m experiencing with my War Thunder account.

Recently, my account was hacked, and after contacting support and changing my password, my account was permanently banned. I have already submitted a support ticket explaining the situation and provided all the necessary details and evidence. Today, I attempted to log in to check for any updates on my ticket, but I found that my password no longer works.

I have tried resetting my password multiple times, carefully following all instructions, but I am still unable to access my account. Here are the steps I’ve taken:

  • Reset my password multiple times using the official password reset process.
  • Ensured there were no typos or errors in the new passwords.
  • Tried logging in from different browsers and devices.
  • Cleared browser cache and cookies.

Despite all these efforts, I still cannot access my account. I am concerned that my account may still be compromised or there might be another issue preventing me from logging in.

If anyone has experienced a similar issue or has any advice on how to resolve this, I would greatly appreciate your help. Additionally, if a War Thunder support member could look into my case, that would be fantastic

It turns out that the issue was due to my email address being changed by the War Thunder support team. Although I wasn’t able to see their reply initially, they still proceeded with the email change, which is why I couldn’t log in.

I have now managed to access my account with the new email, but I am still facing a ban.