Switching from WIndows 10 to Linux, can no longer use High Textures, and game only launches on one monitor

ASRock Z75 Pro3
16GB DDR3 RAM
i5-3450
GTX 960 2GB VRAM
^ I have checked, the system is corretly showing the 2048MB of VRAM.

Using Dedicated Linux Launcher, no steam.

As title reads.
After fiddling for hours, as a new Linux user now just switching today, I’m no longer able to access High texture settings, while before on Windows 10 there were no problems with such, and also, the game is launching on my secondary monitor, which is to the left of the Main.

So far:
Me and a friend have more than less confirmed WT is using my dGPU, not iGPU, though it’s not 100%,
as Linux is new for both of us,

We have fiddled with plenty of ways to launch the Linux version of the game to see if that fixes the issue, including launching it as a non-steam game and adding a few parameters, some sort of “gamemode”, “gamescope” which never worked and lastly, using “__NV_PRIME_RENDER_OFFLOAD=0” in terminal before launching both the launcher app. and aces app…

None of these have done much.
However, my quick work-around so far for the latter problem, of the game launching on the wrong screen,

is Super + SHIFT + RightArrow, which moves the screen to the correct monitor, so that’s not a big issue.

Is there anything else we can try, do, or anything to maybe be able to use High Textures?
It won’t drive me away from the game, but being a Simulator player and also just enjoying the models quite often, it is a little offputting after switching to Linux.

I hope I provided plenty of information about everything, sorry for the bother,

and thank you to anyone that might help here!
-Atom

3 Likes

Hello @AtomtheBadDragon,

Regarding the “high” texture quality settings not working, This is a known issue with the WT Linux client and GPUs with 2GB of VRAM or less.

As for it launching on your secondary monitor, Could you please post what Linux distribution and version you are using?

I am currently on Linux Mint 21.2.

Although that secondary issue is not that big of a deal, it is still an issue I think should be resolved for QoL.

Though either way I will be dual-booting Windows as Linux is not a great way still to play many of the games I do, but thank you for replying anyway!

1 Like

Right, Have you set you main monitor as the primary one in the system settings for Mint?