Strange problems with radar keybinds and zoom with the new update

With the new patch Sons of Atilla The Aircraft Vertical Radar/IRST target cue control axis, key ALT+W can achieve upward movement ALT+S but can not perform downward movement, However changing the downward to any other key makes it functional again but then rebinding it to again ALT+S does not work, What gives? Im not so keen in changing these keybinds that i’ve come very acustomed to due to what appears to be a strange bug.

The Z keybinding for Zoom had been disabled for both air and ground vehicles, Previously it worked as a toggle, a single Z press would result in a zoom in and pressing it again would make it zoom out again. Upon rebinding the Z as zoom it is now a hold down feature and not toggleable again. I have been unable to fix this as I want it to go back into being a “zoom toggle”.

I notice that the RMB still works as a toggle zoom for ground vehicles. For air vehicles RMB works as a toggle zoom as long as you have not got any enemy vehicle marked upon which it zooms in and tracks that target.

Help would be very appriciated.

Noticing that others on the Steam forum has the same problem

Same thing happened to me. Here’s how to rebind:

  1. Controls
  2. Common
  3. View Controls
  4. Zoom Camera

It should say its only bound to RMB, so add Z key back. Even though its on the same bind it will not track like RMB, only zoom.

1 Like

Thank you solved the zoom part of my question!

hey had this same issue and just fixed it! just above the keybind for the radar you want to be set to ALT+S there is another keybind using s+ALT+S i think it was for changing pitch of adjustable guns. i removed that and the radar keybind works now.

1 Like

Thank you that fixed it!