[STEAMDECK] Gamepad User Interface Option Missing

I wasn’t sure where to post this as the steamdeck technically isn’t listed as one of the platforms for this category, but I suspect this issue is specific to this platform based on what I have seen. Apologies if this is in the wrong place.

For various reasons, it is difficult (if not impossible) for me to use controllers. I got a steamdeck for traveling since it is small, and it can be docked so that you can plug in a mouse and keyboard natively without any sort of modification.

The problem I have with war thunder is that it is forcing me to use the controller interface even when I have a mouse and keyboard connected. If I set the controls to mouse and keyboard in the controls wizard, it is still using the controller interface. There is supposed to be an option under Options > Gamepad to enable or disable the gamepad user interface, but this option seems to be completely missing on my steamdeck.

This makes it incredible difficult for me to do simple things in the interface with my mouse and keyboard. For example, I am unable to unbind a key from a control since there is no way to keep it selected and simultaneously click the “unbind” button at the bottom of the controls window, because as soon as I move my mouse off that control, it doesn’t keep the control I want unbound selected (it wants me to press down one of the thumb sticks instead). It also seems like this interface is interfering with my ability to bind the throttle to my mouse wheel, but that may be an unrelated issue.

My question is, how do I simply disable the “Gamepad User Interface” option on the steamdeck?

Hello @Sturmgewehrz,

Could you please submit a bug report on the bug reporting platform here:


Making sure to upload all required files and information. So a in game screenshot (Created by the game using the key/button bound to the “Screenshot” function) of the Options menu where the “Gamepad User Interface” option should be. (Options > Main parameters > Gamepad) and a .clog file from the same session as the screenshot.

Figured it out. In steam, you have to switch the controller options for this game to steam input. Then you have to change the controller layout to be one of the templates that only passes mouse and keyboard inputs to the game (the default passes xbox controller inputs to the game). After doing this and restarting the game if it is currently open, not only is the option for the gamepad interface available, but it is disabled by default.

I will try to submit a bug report when I get a chance, I’ll have to revert the changes I made to reproduce the issue though.

Right, Thank you. Glad you figured out it can be changed through Steam like that.