Problems with CDK

I recently downloaded the CDK but when i want to install it this error pops up
I dont know what to do pls help.
Thx :)

I completely reinstalled the game but the same error is always poping up. And yes I installed the CDK in the correct folder as you can see in the screenshot above.

Yea, nah, it’s broken, and has been for a couple of patches recently.

You’ll have to wait until it’s updated seeing as the last update it had was in February…

(Edit - That error though, seems to hint at a write issue, so maybe make sure the game’s not open, or that the antivirus isn’t messing with it, or that the drive isn’t full)

1 Like

wdym with that the antivirus isn’t messing with it, what can I do to fix it?

I’d be waiting until the next update to the CDK comes out. There’s a few people having issue with the CDK currently, and in the meantime I’d be considering a switch to the native Gaijin launcher.

Or, make your steam library path shorter, as that limit of so many characters in a file name could be something with this one… (This could be your actual issue)

Hey thanks for the response. But how do i make tha path shortter? :)

I made a new steam library at the root of my drive as mere ‘games’ and then that removes the \program files\steam\ portion shortening the path.

Have a look on youtube about moving your steam games, and managing the steam library.

It’s good knowledge to have.

Myself, I run 4 SSDs on my machine, both mirrored, one pair for the OS, one pair for my games. It makes loading the games real fast.

1 Like

I wanted to start it but then this poped up:
and after it this poped up:

What is this and how can I get rid of it?

I have no idea, but if you only linked your war thunder account to your steam account, I’d try use the native gaijin launcher and install the game to a 'c:\warthunder' kind of folder. If you created it through steam, I’d be hesitant on going that far.

That error could be leading you to need to clear out the game folder and start over.

As I said though, there’s a few reports of the CDK having issues at the moment, and I’d wait until the CDK is updated before getting into it.

I’ll wait till the next cdk update. Thanks anyways.
One last Question. I had the cdk once on my Computer and warthunder was installed via steam but everything was okay, do you maybe know why?

Checking the filename length on your error it doesn’t seem like the length would be affecting it, but it’s getting very close to the 256 character limit. It’s at 219 or something. (The only reason I know about this, is when I had a backup that was nested so far in folders that it broke and was unable to be moved or worked with because it was that long a filename.)

No idea on why it’d be playing up now, but things get added and changed a lot in some instances.

I myself use the gaijin launcher alone on my end, I only fire up steam on another machine to play.

It also shouldn’t affect it really, but if you are a gaijin login user who linked to steam, and not a steam user who created an account through there, it’d be easy to use the launcher installer and make its own dedicated folder, and add the CDK to that.