PC restarted after clicking sign in, would not load to hanger

For some reason my PC after clicking sign in would restart itself before reaching the hanger. After verifying files to no avail, I updated my GPU drivers which hadn’t been updated since last October. I then also launched the game with manual update and launched it without running EAC. After loading in to hanger successfully, I closed the game and then launched the game normally. EAC prompted me to allow it to perform actions on my PC which I allowed, and then after finishing loading to sign in and clicking sign in, I was able to load in to the game normally.

Some googling was mentioning this could be related to my BIOs needing an update, which is a rather arduous task. Thankfully the issue appears resolved.

If anyone else has a similar issue feel free to comment on this thread w/ trouble shooting tips / things you tried. I will update if the game has issues or my PC restarts similar to before.

EDIT: Before updating my drivers I went to WT’s game files and launched the “EasyAntiCheat_setup” in the “EasyAntiCheat” folder to repair. I believe I still had my PC restart after launching with just having done this though.

UPDATE: After playing through an Air RB match, closing the game, and launching it again normally I was able to get back to the hanger without issue. Knocking on wood no more issues.

Well it seemingly was fixed but has just done it again. I presume it’s related to EAC.

Well launching the game manually again with EAC off, closing it, and then running the EAC repair has once again allowed me to enter the game normally. It again asked me to allow EAC to make changes after I launched normally.

Weird and confusing.

Able to get to hanger normally after playing a few games and relaunching the game again. Some googling also mentioned EAC likes to detect RAM being faulty? Maybe an issue there although the game underload runs just fine it’s on start up that issues have arised.

No performance differences ingame. Have not tried other EAC titles yet to see whether the issue is duplicated there.

When you did this, what exactly did you do?

And did you do the antivirus exemption for the game folder, as well as clearing out the cache folder in the game folder as well as the compiledShaders folder for a coverall?


WT’s files from Steam, EAC folder, ran EAC set up which gives option to uninstall or repair for “GAME 45” which I presume is War Thunder since it says “CURRENT GAME”.

Then do it…

And one of the key things with that instruction is TO RUN THAT AS ADMINISTRATOR

If the issue persists again tomorrow I’ll try that.

I mean I can, I’ll probably try reinstalling it next if the issue persists.

You absolutely need to follow the instructions rather than half-assing it… That executable needs admin rights, and EVERYWHERE it’s mentioned about it’s ALWAYS said to run it as admin.

And if you’ve got antivirus on your PC, (And even if you don’t as windows defender can even mess with things) you need to make that exemption.