PC client stuck in gamepad mode, showing all joystick inputs as gamepad buttons


To preface, I’d like to 1) apologize for the length, I’ve not found any even remotely similar issues online, and 2) emphasize that the “Gamepad User Interface” option is off, and I’ve tried toggling it. This only changes whether the Xbox/Gamepad buttons are present on other portions of the UI besides the Controls menus, i.e., all buttons on the main menu. Unfortunately, it seems to have no effect on the UI of the Controls menus, which is where my issue is limited to.

I’ve been having this issue for approximately a month, but haven’t had the time to fully research and troubleshoot it to my satisfaction until this weekend. To provide a necessary bit of context, I was briefly provided a demo Asus ROG Ally unit through work right around their launch in mid-June. In the course of trying to test it, I logged into Steam and installed War Thunder, as well as a few other things. After a few hours of downloading via painfully slow work wifi, I booted it up, selected the gamepad control option in the setup wizard (without any thought at this time as to how it might impact my home PC settings) and spent a few minutes going through that before I was interrupted by work bullshit. At the end of all this, I don’t even remember if I was able to get into a single game, or if I just struggled around in test drive. In any case, I uninstalled it and logged out of Steam the next day, as I was not going to be the only person with access to the demo unit.

My actual problem began when I tried to play from my home PC following this. Since then, despite any and everything that I have tried, the Controls menus seem to be stuck in a gamepad UI mode.

This might not be a huge deal for the average player as KBM inputs are still shown, albeit still with a slightly different UI, but I largely play Air SB, and I have a lot of peripherals. Not all of them are for WT, of course, but my underlying method for streamlining them is the same: hiding all of the peripherals from almost all applications using HidHide and combining them into two virtual joysticks using vJoy and Joystick Gremlin. I’d prefer to combine them into one, but vJoy has an 8-axis limit per joystick.

This is a little inconvenient for War Thunder because of the way that the game recognizes more than one vJoy device, which seems to be: whichever it happens to detect first when it runs. Because I have control inputs across (4 different joysticks and throttles mapped to) two vJoy controllers which, on any given instance might be recognized by WT as either C1 or C2 interchangeably, I’ve had to develop a habit of checking and remapping a dozen or so controls every time I start the game. It’s fine. It’s like a Pre-Flight checklist right? I’m used to this part lol.

Unfortunately, my attempt at testing the ROG Ally has derailed even this cumbersome routine. Since the moment I booted the game on the Ally, my Controls menus have been stuck in some sort of gamepad mode on my home PC, which means that most of my dozens of joystick inputs are showing up as big-ass yellow “Y” Xbox buttons and the like. Once mapped through the Wizard, the Controls are usable for that session, despite the UI, but this is a huge pain in the ass to do for every play-session, far more than the relative handful of controls I was habitually checking already.

I’ve tried about everything that I can think of, including:

  • Toggling the Gamepad User Interface option. I promise you this isn’t it.
  • Clearing my Controls in-game and starting from scratch, both manually and with the Wizard. I feel it’s worth noting that the controls are recognized and displayed appropriately in the Wizard, but when you view the Controls after, they’ve reverted to Gamepad buttons, which also points to a UI-only bug
  • Repairing the game using both Steam and the Gaijin launcher
  • Clearing my Controls and uninstalling the whole damn game and wiping every trace of it from both my Steam Library folder and User AppData folders
  • Launching with just my naked peripherals (not hidden with HidHide) and no virtual joysticks
  • Repairing the drivers for all of said peripherals
  • Checking and disabling all Gamepad settings through Steam

Here is my system and peripherals for reference:

  • i7-11700KF
  • G.Skill Trident Z Neo 2x16GB DDR4-3600
  • TUF GAMING RTX 3080 10GB
  • WD Blue SATA SSD 4TB (game drive, OS is on its own NVME)
  • 45" 3440x1440 primary monitor, 27" 1080p secondary


  • TM Airbus A320 joystick
  • TM Airbus A320 Throttle (x1) and Flap/Airbrakes add-ons
  • TM 1600M joystick (connected but not used for WT)
  • TM TWCS Throttle + Pedals
  • TrackIr
  • Logi G923 Wheel/Pedals/Shifter (connected but obviously not for WT lol)
  • Xbox Elite 2 Controller (not ever connected/turned on at the same time as WT, but the drivers were there, until recently, as was an 8bitdo wireless USB adapter used with it)

The peripherals not used for WT are always hidden from it to avoid messing with the Controls settings.

This is driving me crazy, and has largely kept me from playing at all over the past month. Any suggestions?

1 Like


make a bug report