Nvida “capture important moments”

I’ve had some lethal frame drops from 160+ to 0 for a few seconds. It always happens when the NVIDA captures a death or a base destruction. It happens in ground more than air, all my drivers and game is up to date, any ideas?

Yes. Turn it off in GeForce Experience.

1 Like

I had similar issues with this Nvidia feature, disabled immediately.
I suppose this function sucks a lot of resources, unles you have an high end pc, with very fast SSD and cpu, I suggest to leave it off

Idk about my SSD, it probably isn’t great speed wise, but my CPU is a Ryzen 5700 x, so it’s not super slow, I can run multiple games at HQ at a time as far as GPU goes. I will turn off those features.

1 Like

Limit the game FPS in the nvidia control panel, found this has fixed like 99% of the visual issues with the game.

At times the game tries to render indefinitely (bad or dated engine) that will just hog down your system.


1 Like

Thanks, I will try 👍

like every game does when neither vsync or a frame limiter (either internal or external) is enabled
so this is neither related to a bad nor a dated game engine but totallly normal…

Commonly I find the trouble with this, is that you’ve got the game on the same drive as windows, and then same drive as the video cache.

SSDs for all, to different drives may help out if you haven’t done any of this.