My missiles refuse to start on the first attempt

I am way too often dying to r27s because 1: f-16 can’t maneuver quick enough to start notching and 2; since i can’t maneuver on time i usually prepare an aim9l before heading on the enemy to take the missile down and proceed to dogfight the enemy. I have a single button assigned for the missile turning on action, but also since gaijin changed the action to both turn on and fire i dont know where or how can i get a “turn on missile seeker” key so that it doesn’t overlap, as for the missile would just show the seeker for a split second and not spool up in the next 10 seconds. It happens way too often and too consequently and it’s awful.

I’ve found that for me (at least in SB) the best way to queue up a missile is to use the “Weapon lock (air to air)” keybind and then fire it with the “Fire secondary weapon” I think “fire secondary weapon” will arm a missile, but using the other keybind first, does feel a lot smoother. This method of firing though does require the use of weapon selection and physically changing what secondary weapon you have selected.

I dont have any experience in an F-16, but in a Tornado F3 I tend to fire off my SARH (Skyflash ST) and then immediately swap to and arm my Aim-9L so that I can fire it off ASAP.

Separate “Weapon Lock (air-to-air)” and “Fire air-to-air missile” controls. Use the former to warm up missile and latter to fire it.

1 Like

aha so it’s weapon lock the option i was looking for, thought it was something showing up by searching “missile” on the controls tab, but it wasn’t since “missile” only gave me the single option of “fire air to air missile

thank you juno.