Mouse recognised in menu but wont work

Hey players, I’m having odd issues with my Logitech MX Lift mouse. When I assign functions to mouse buttons 4 and 5 in-game, they don’t seem to work. I’ve tried reinstalling drivers, checking macros, and even tested another Logitech vertical mouse which works fine. This situation is frustrating since I rely on this mouse to reduce RSI and utilize Logitech Flow with my tablet. Logitech support suggested binding the buttons to “Forward” and “Back” in the software, which I’ve done, as there is no option to set them to mouse 4 mouse 5 but it’s still not working. Any tips or pointers to resolve this? Thanks!

Hello about your buttons 4 and 5, they’re not specific commands but shortcuts.
You need to use the “Logi Option +” software and define which keys on your keyboard you want to link to these buttons.

For example, on my mouse, I have a button on my thumb, which corresponds to the ’ key (this one corresponds to rocket fire when I’m flying).

hey i went into options + and set button 4 and 5 to keyboard shortcut num pad 2 and num pad 8, this is again picked up in the menu settings as i would expect however in game it does not respond at all. im lost as it can pick it up and it works while binding the key but does nothing while playing???

I was having this same issue with my logitech MX mouse. What i found is the thumb buttons are also used for sidways scrolling. If you ho into options+ you can dissable sidways scrolling. This solved the issue for me. My guess it the game was confused by one button trying to do two things

I’m having the same exact issue with a Dell 7 button mouse. All of the buttons are recognized and bindable in the control settings, but in the actual game only 5 of the buttons work. The fact that this is occurring across multiple devices and manufacturers strongly suggest an issue in the game.