macOS - game will not launch after Seek & Destroy update. Not in-game EAC issue

After the Seek & Destroy update War Thunder will not launch on my Mac. I updated via the Launcher this morning, then after attempting to start the game, the icon just bounces in my dock. Tried restarting, tried removing the cache folder (followed by a restart), tried uninstalling and re-downloading the Launcher and entire game from the Gaijin site, then installed Steam and downloaded the game via the Steam client all with the same result.

Also tried opening the app directly from the “Show Package Contents” option in the War Thunder Launcher to no difference. I always have to Force Quit the app and try again.

It had been working fine for the last 6-7 months and up until last night. Running a 2023 M2 Mac mini on Sonoma 14.5.


Seconding this issue. Same this happens when launching on my 2020 M1 MacBook Pro, running Ventura 13.2.1.


Same issue here. 2017 Imac desktop. Latest patch doesn’t fix the problem


Well, I’ve got good news and bad news. Good news: it just started working on my Mac. Bad news: I didn’t do anything to make that happen. I left my computer alone for several hours and when I returned, the app was open and at my hangar. I’ve been able to quit, restart my Mac and successfully re-launch the game multiple times since.

1 Like

Sounds like Gaijin broke the way the loading system works for the game on Macs end.

1 Like

ive got some minor updates after seek and destroy and it didn’t do any thing


did you leave your Mac with WT working or did you start from the beginning

from my perspective WT bounces for 2 mins then it stops bouncing but without launching
It says that it isn’t responding and then I force it to quit

1 Like

for fact i play it on external ssd

1 Like

Same problem, the icon of WT just jumping on my deck and unable to open


was having same issue but left the game trying launch for a bit then it started working, but is laggy and hitches a lot.
2018 Mac Pro

1 Like

It just started working normally again for me. No change on my end, other than trying again after 30min.

1 Like

Same and the same issue is happening to me

I updated the game last night and it didn’t launch after many attempts. I deleted the game off my external SSD and redownloaded the launcher. I then waited for hours for it to finally download full HD and it just finished. the same problems are happening on my mac.

FWI: My Mac is a 13 inch M1 2020 running Sonoma 14.5

gaijin fix this pls I need to continue the grind

same here

1 Like

The newest newest patch also doesn’t resolve this issue. Ive seen someone say it was fixed after they let it sit and load but that doesn’t appear to work on my end

Same issue here, I deleted the game and redownloaded it but still nothing…

Same issue here, War Thunder didn’t Launch at all after clicking play button on the Launcher. Running Ventura 13.6.3

1 Like

I also thought WT would not start on my M1 after the update yesterday.
Went to do something else and what do you think? After 30 Minutes or so the game started. Now there ist no issue (at least with starting WT) any more.

Maybe its the game verifying again after the update? Maybe the verification progress bar just doesn’t show up like usual which is why the game shows app not responding?

It still won’t open here. It bounces up and down for a couple minutes then just stops bouncing without even opening… did you do anything to make it work?