Linux crashes

Hello! I run war thunder natively through steam, it loads the Vulkan shaders, then poof! Gone.

However, the work around for this is to install (any) proton version for war thunder, run it. Let it crash. Turn off the proton. Then let it update again, then runs fine…

Running verify game files doesn’t affect the crashes.

INXI -F:
System:
Host: pop-os Kernel: 6.6.6-76060606-generic x86_64 bits: 64
Desktop: GNOME 42.5 Distro: Pop!_OS 22.04 LTS
Machine:
Type: Desktop System: PC Specialist product: MAXIMUS IX HERO v: N/A
serial:
Mobo: ASUSTeK model: MAXIMUS IX HERO v: Rev 1.xx
serial: UEFI: American Megatrends v: 1301
date: 03/14/2018
CPU:
Info: quad core model: Intel Core i5-7600K bits: 64 type: MCP cache:
L2: 1024 KiB
Speed (MHz): avg: 2000 min/max: 800/4200 cores: 1: 2000 2: 2000 3: 2000
4: 2000
Graphics:
Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nvidia v: 545.29.06
Display: x11 server: X.Org v: 1.21.1.4 driver: X: loaded: nvidia
unloaded: fbdev,modesetting,nouveau,vesa gpu: nvidia
resolution: 1920x1080~60Hz
OpenGL: renderer: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2
v: 4.6.0 NVIDIA 545.29.06
Audio:
Device-1: Intel 200 Series PCH HD Audio driver: snd_hda_intel
Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel
Sound Server-1: ALSA v: k6.6.6-76060606-generic running: yes
Sound Server-2: PipeWire v: 1.0.0 running: yes
Network:
Device-1: Intel Ethernet I219-V driver: e1000e
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full
mac: 10:7b:44:a6:69:ef
Device-2: Realtek RTL8812AE 802.11ac PCIe Wireless Network Adapter
driver: rtl8821ae
IF: wlp3s0 state: up mac: d0:37:45:2a:2f:6a
Drives:
Local Storage: total: 2.16 TiB used: 272.5 GiB (12.3%)
ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 PRO 250GB
size: 232.89 GiB
ID-2: /dev/sda vendor: Seagate model: ST1000DX002-2DV162 size: 931.51 GiB
ID-3: /dev/sdb vendor: PNY model: CS900 120GB SSD size: 111.79 GiB
ID-4: /dev/sdc vendor: Western Digital model: WD1003FBYX-01Y7B1
size: 931.51 GiB
Partition:
ID-1: / size: 219.31 GiB used: 89.38 GiB (40.8%) fs: ext4
dev: /dev/nvme0n1p3
ID-2: /boot/efi size: 1020 MiB used: 394.5 MiB (38.7%) fs: vfat
dev: /dev/nvme0n1p1
Swap:
ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%) dev: /dev/dm-0
ID-2: swap-2 type: zram size: 15.56 GiB used: 256 KiB (0.0%)
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 47.0 C mobo: N/A gpu: nvidia temp: 62 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 37%
Info:
Processes: 333 Uptime: 2h 18m Memory: 15.56 GiB used: 8.98 GiB (57.8%)
Shell: Bash inxi: 3.3.13

Hello @sphunt2005,

So are you still getting these crashes? Also is it the launcher or the game client that is crashing? Do you get any error messages?

Yes, and both. Opening the game, crash. Open the launcher, crash. No error messages.

Right, Could you please download the latest WT Linux launcher from our homepage (https://warthunder.com/en) and extract the “WarThunder” directory from that archive. Now copy the contents of that “WarThunder” directory into your main “WarThunder” directory that has the launcher binary in it. Making sure you overwrite all the launcher files.

Once you have done that, Does the launcher start?

Hello i’m having the same issue. Running on native mode. haven’t tried proton yet but there are issues with EAC.

Operating System: openSUSE Leap 15.3
KDE Plasma Version: 5.18.6
KDE Frameworks Version: 5.76.0
Qt Version: 5.12.7
Kernel Version: 5.12.15-0-default
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-9700K CPU @ 3.60GHz
Memory: 62,7 GiB of RAM
Graphics: Nvidia RTX 3060 12GiB Vram

I use steam to launch the game and now it crashes with no crash logs on both options. Problem seems to be the steam login. Using the launcher in the game files i can log in and launch the game with no issues. But i’d like to fix this because its inconvinient to launch it using the launcher.

Hello @BestLinuxGamer,

Where is it crashing exactly? Before or after login etc.

On startup. When selecting the launcher with steam. game crashes with no logs.
Using the “Play War Thunder” launch option goes to the status launched for less than a second and crashes with no logs too. There seems to be the issue with the steam login since non steam launcher is working native.

Right, I see your on OpenSUSE Leap 15.3 which is End Of Life and no longer getting updates, Could you please update to the latest version of OpenSUSE (15.5) and see if the issue persists?