Launcher error

When pressing “Play” in the launcher, the launcher closes, before EAC launches, only for the launcher itself to reboot.

Launcher is currently on, which i beleive is to be wrong. Possible error is that the launcher have failed to update itself. Any suggestions for a solution, other than uninstall and reinstall the game?


After having the launcher open for a while, this message appeared: ---------------------------

Disk read/write error. Would you like to try again?

Yes No

Pressed “yes”, only for the launcher to close and reboot again.

delete the D:\Games\WarThunder\WarThunder\content.hq\hq_tex\res\hq_tex_vietnam_cliffs.dxp.bin and run the launcher again

that’s the game version and it’s correct

1 Like

Thanks, but that did not help.

After i received the “Vietnam” error, i also received an error regarding textures on the f14b. I pressed yes on that window as well, and the launcher updated. Then i suddenly were able to enter the game.

Now, when trying to start the game again i face the same problems with the launcher re-appearing. Ive tried removing the vietnam.dxp.bin file but it doesnt work.

something seems to inhibit the launcher from doing its job (properly). this can a few things…

  1. a faulty (or failing) hard drive - very rare nowadays but still you should check your drives for errors

  2. broken game files (for whatever reason) - however usually the launcher catches those and just repairs / redownloads them.

  3. system protection / anti virus softwares blocking access to some game files - either seeing them as a (potential) threat preventing access to them completely or it just takes too long to check and the launcher cannot access the files while the checking / analysis process lasts. this can often be circumvented by temporarily disabling the protection / av software whilst the launcher is updating the game / checking game files or adding the WT files / folder(s) to the exclusion list in the av software - this is a very very bad idea (imho) and should only be kind of a ‘last resort’ option

do you mean you got the error again after removing the file and running the launcher afterwards or couldn’t you delete the file at all (while the launcher is NOT running) ?

Did not get the error again after trying to run the launcher, but the launcher just reboots when pressing Play.

Sometimes the game freezes, so i have to disconnect the external hard drive. If i remember correctly last time that happened was when i played on a Vietnam map.

Anyways, i ran a file check from the launcher window, which resulted in a succesfull boot of the game. I have not tried again since, but will try later, so ill report back then.

By using the “Check files” button in the launcher i can again access the game.

Exited and tried again, launcher just reboots. Pressed the “Diagnostics” button, and after that was done (took less than 30seconds), i was able to enter the game.

I’m having the same issue, except that the “Diagnostics” and “Check Files” buttons don’t work.

1 Like