Issues with the new update "Seek & Destroy"

hi, im having trouble with the game after this update, when i start the game it’s alright but after i move my mouse the game looks like is not responding to the click of the mouse, i already restarted my pc but the problem still there, any tips? thank you.


Yea you ain’t the only one. I am facing the same problem, and talked to a few on here already, and think it is most likely due to issue with patch day lag, that casue problems. We may be wrong in this regard, so don’t fully qoute me on it


MacOS game not connecting with steam account and web login not working from login page on game


A lot of troubles on patch day, nothing new really

1 Like

i got it too. my game freeze after i move my mouse. Sometimes i can go in the hangar but i cant click on Something

Yea a few have gotten that problem from what i have gathered, and all we can do is wait for the devs to fix it, so who knows when that will happen

Have you gotten any updates on your situation? My friend has the same Problem and I would like to help him. Thanks!

Hi there. I play on Mac and I don’t find this problem, hoewer every time I start a match, the game automatically bans me from there saying its an Eac (easy anti cheat) thing, someone the same problem??

1 Like

Ok When i Start the game and not Move my Cursor i can click the buttons but when i move it i cant Anymore

1 Like

Everyone who is having this issue, try force ending the overwolf/outplayed overlay in task manager.


puo essere forse un problema che il gioco non “identifica” l’anticheat, quindi io ti consiglierei di verificare di non aver nessun altro gioco con lo stesso anticheat aperto e magari ravviare il mac e sperare che funzioni

1 Like

same for me

Grazie mille per i consigli
Girando per il forum ho scoperto che è un problema comune a tutti i Mac e nessuno sta trovando una soluzione, quindi mi sa che è proprio una gabella di Gaijin/Mac

1 Like

Same problem, rebooting laptop/checking the files integrity through the launcher/reinstalling the game did not help

I noticed this bug on the dev server and was hoping it wouldn’t make it through to the live server. But closing Overwolf fixed the issue.

1 Like

O man Thank you sooo much i kiss your balls it worked. after i closed Overwolf the game dont freeze anymore and i can click the hud

I am having the same problem. Instead of Steam logging me in, it brings me to a War Thunder Log in page and I don’t have a direct accout with WT

yea so I searched a bit and found out is a common problem for Mac players, still no solution to this…

I cant to lunch my game on my Mac, the luncher will open but when i click on the play button the luncher close and the game didn’t start.

t happens the same to me, and I haven’t found a solution yet.

1 Like