I enter a battle, then the game crashes after 8-9 minutes

I’ve been trying to do simulator air battles, but the game crashes after around 8-9 minutes of gameplay. A popup shows up with the message “Exception” and then the crash report popup shows up. It also happens if I do an arcade battle with EasyAntiCheat off.

My computer specs are the following:

OS - Windows 10 Pro N 64-bit
CPU - 11th Gen Intel(R) Core(TM) i5-11400F @ 2.60GHz (12 CPUs)
Memory - 16384MB RAM
GPU - GeForce RTX 3060 VENTUS 2X 12G OC
Network - Ethernet connection, 500Mbps download speed, 100Mbps upload speed

Here are the logs for the latest crash:
latest-breport-clog-dmp.zip (1.5 MB)

And also the logs from the two previous ones:
54ff775afd.zip (1.9 MB)
ad48a567f1.zip (1.4 MB)

Also some logs of arcade battles:
arcade-logs1.zip (1.6 MB)
arcade-logs2.zip (1.4 MB)

Some of the things i’ve tried without success:

  • reinstalling the game
  • clearing the game cache
  • reinstalling the graphics card drivers
  • making sure all my other drivers are working properly
  • running the game with the lowest graphical resolution
  • use the “GeForce Experience” recommended graphical settings for WarThunder
  • playing without joystick plugged in (keyboard and mouse on simulator battle)
  • installing War Thunder on the same drive as Windows (I usually put my games on a separate partition and i read somewhere that WarThunder sometimes doesn’t like that)

Does anyone have any advice? I’m going insane trying to fix this.

Updating the BIOS fixed it!