Horrendous loading and playing experience since Sons of Atilla (roughly)

Roughly since the update for Sons of Atilla I have been having the most awful experience with WarThunder… 5 minutes for the game to even load (when it doesn’t hang), 5 minutes + to actually get to the game screen to allow me to choose a vehicle. FPS at 17 at best (often drops to 1-2 or so) even on LOW graphics…

have reinstalled the game
updated graphics driver Nvidia GEFORCE
updated network adapter driver

I know others are having similar issues but just needed a thread for my situation

PC Spec (worked OK before latest patch)

Processor| Intel(R) Core™ i5-5200U CPU @ 2.20GHz 2.20 GHz
Installed RAM|8.00 GB
Windows 10
Nvida GEFORCE 840M - 8GB memory (driver dated 21/09/2023)

I suppose you have deleted WT cache; did you delete all Windows cache files ?

1 Like

deleted WT yes, all windows done as well via Disk Cleanup… seeing really slow performance on network vs other devices in the house (all windows 10, all newer than my laptop)… have disabled/enabled network driver (I use LAN cable) and tried wii to no success

seems to be related to bad network connection… getting 1/3 download speed as other devices in the house… any ideas how to resolve?

am thinking this might be windows update related. deleted all but 1 since the last resonable performance - can’t install the last one as it is some special update, so resorting to a reset of my laptop and then reinstall things…

If you use wifi, it plays up REAL bad…

Also if on a laptop, if on battery power and not plugged in, it does silly powersave stuff… Turns the power management on…

have a wired connection (pass through plug) and always play plugged in… definately started happening AFTER the last 4 updates were installed (so I know it isn’t the latest game update as that was a day or 2 earlier)… if this doesn’t solve it it is new hardware time (its an old laptop anyway)

If you use the gaijin launcher, and not steam, there’s a P2P sharing option in the launcher, and if you turn that off it could make it better.

It’s somewhere in the wrench menu in the top right of the launcher, change it to HTTP or something in there.