Ground texture flickering while flying

Something weird that never happened before the latest updates, in EC sim - from cockpit view - the ground textures flicker between low res and high res - a lot and always.
I made a small video to show it, the game is running on a PC with a legit version of Windows 10 PRO 22H2 (latest updates)

The video got ccmpressed by imgur but you can still see the ground morphing as I turn my head around and, at the end, the straight up low to high res texture swap when I press the zoom button

I reinstalled the game deleting any leftover or config file, also I reset the video card shader cache in Adrenalin software (I’m running the latest driver 23.11.1), everything is maxed out, HDR enabled and resolution is 4K.
Vsync is off but I’m limiting the fps to my TV refresh rate with Rivatuner, but this happens even if I don’t limit the framerate.

I reinstalled the game with the complete client without HD textures, before reinstalling I had only the plane HD pack, in any case the problem persists.

Obviously the game is unmodded (not even skins)

Any ideas?

It is way worse when you play in ground mode.
There, whole buildings, or even mountains completly disappear and reappear.
It is the usual Gaijin breaking abother thing…

1 Like

In your place, i would not worry about hardware malfunction, maybe except if you use Radeon VII, but even then, you are pretty safe.

Tho if you want you can always repaste the GPU/CPU, and do basic maintenance.

Also, are the temps OK on your hardware?

Can your hardware handle 4k max setting?

1 Like

Yes sir hardware is fine, I have a 6900xt which I modded adding thermal pads on the backplate, vertical mount and edited its bios to get more power, this way I managed to undervolt it while keeping high boost clocks, temps are around 30° idle and never go higher than 70° degrees under stress (moreover the 120fps limit helps in not having it run at full speed drawing useless frames)

Wont repaste just because my model is the Radeon reference one, which uses a graphite thermal pad that has looong end of life (videocard is less than 2 yr old), I was also lucky because the delta between average and hotspot is less than 8°C and this means the pad contact is even!

PS: without fps limiter the gpu pulls from 150 to 200+ fps during average gameplay so on that regard is fine

Also the game is installed on an nvme 990pro so really I can’t think of any reason it does that flicker other than some game engine related problem introduced with the latest updates

1 Like

Yes, it is more then likely the case. Many people with a wide range of hardware experiences this issue, so classic Gaijin mess up situation.

I am still rocking with a nearly 10 year old setup, with a Xeon E5-2680V3 (12C/24T) with all core turbo unlocked, and with an Nvidia Tesla M40 (Gtx Titan X (Maxwell) datacentre version), alongside with 32gb RAM.
I have built id in the middle of the pandemic, and the whole system (the only thing i did not buy was a case) cost less than an RTX 3050…

The only downside of this is that i can’t play realistic, because this trash rootkit, i mean “anticheat” the game has would flag my system, because of the weird driver and hardware combo.
There was a thread about it, and it was just deleted by mods…

1 Like

Yeah that’s really frustrating… modern anti cheat often cause more harm than benefit, I wonder why they don’t use the good old punkbuster, it run on anything and was pretty neat back then, from what I know it’s still developed

I never heared about that.

The issue is not just that EAC false flags a lot of people and does not catch anything real, manual bans are very rare too, with mountains of evidence…

Similar issues. Really prominent when I fly planes

Max settings, SSA 4X, no other AA.
1440p@170hz (capped my framerate with adrenaline), 7900XT

I’ve recently build a pc with a 7800x3d and 7900xt and I play on a nvme ssd at 1440p 280hz and get the same issue.
I found minor success in setting anasatropic filtering to 0X and SSA to 0X but then things become blurry quick making it hard to spot enemies sometimes. I even tried booting the game with a different API like vulkan and DX12 to see if it was the renderers fault but no dice, all I got was a performance boost (if you play on steam use “-drivers :vulkan” or “-drivers :dx12” as a launch modification in the general section of the properties general tab in steam).
GAIJIN PLS FIX.

Apparently there’s ALSO a known AMD problem - this is from the latest driver notes:

Known Issues

Intermittent flickering of certain ground textures may be observed while playing War Thunder with 4x SAAA enabled on some AMD Graphics Products, such as the Radeon™ RX 7900 XTX.

But I have no SAAA active, tested also with no anti aliasing at all and the problem persists, moreover I’m on a 6900XT

I tested some different values for SSAA in the config.blk to no avail. Terrain flickering is really annoying and im on a 7800XT

I have the same issue and I can’t get it to stop. Rather it has increased. It’s extreme in winter maps, or larger maps with sand. I will probably stop playing the game in the future if this persists. I did a thread about it in their tech support but someone wrote that it was anisotropic filtering and they closed it. But I cannot see that it has anything to do with it, it doesn’t change when I play.

“Confirmed to be caused by anisotropic filtering. the more filtering, the more flickering. 2x has very few and very small squares with flickering, 16x has a lot of big squares with flickering. turning it off completely removes any kind of issues.”

Lets make this blow up in some way cause this is crazy!

I don’t know about you guys but I’m AMD 7900 XT with ultrawide screen.

https://community.gaijin.net/issues/p/warthunder/i/iPAsw9fVJHL2?comment=jt7pFnJK9gfC6A6FA4IWgXWS

I have same problem in random rb airbattle

Framedrops from 240fs to 20fps

I upgraded last week to rtx 4060

My gtx1080 runs it just fine even on movie settings

Hello, I made a suggestion months ago, but I never received a response. Since one of the last updates, I have been experiencing a problem on my PS5. When I fly a plane or helicopter in Ground RB or Air RB, there is a flickering pan of ground that appears everywhere.

I have even disassembled my PS5 to check the metal thermal paste, which is sometimes known to bleed, but it seems fine. I also cleaned all the dust, thinking that it was overheating, but it doesn’t seem to be the case.

I play in 4k/60fps without any trouble, but since this update, I have been experiencing huge freezes and FPS drops, especially on naval battles. Every time I take fire because of a salvo, there is a one-second freeze.

If anybody knows if they are working on a solution for this, I would appreciate any information.

Currently, I am having meh moments like, “Hey bro, look how gorgeous this game looks in 4k. Huh, don’t look at the trees or mountains. Oh, and check how smooth it is. Wait… … …nevermind.” What bad advertising.

AMD chipset too…