Ground Forces - Why is spikes/lockon activating with Rangefinder button?

Pressing ‘R’ to range find with certain vehicles equipped with missiles and the lock-on also activates. I have “lock on” bound to another keybind yet it still happens. Is this a feature or a bug?

If you have both binded to “R”, just look for “lock” in the search bar for Ground Vehicles controls.

In this case I use “Q” for “Weapon lock” bind.

Try to change it. But if you use two or more keybinds for performing one action like Ctrl + R for example if it’s for Weapon Lock, try to change it too.

1 Like

They are both different. R for rangefinder and CTRL + X for lock. Yet rangefinder activates it as well.

In this case I suggest you to save the current control settings first in a place where you can access and wipe all the current controls and rebind them and see if it worked.

First go to control’s bind page then Export to file to save your current control settings, this applies to all the controls (air, naval, ground, common, spectator):
image

Then will open a directory page which I don’t recommend changing it and save as .blk file as default:

Then when saved you can press Import from file with the same process: selecting the saved file and it will import the settings to the game.

*Hopefully

When cleared you should also save the new settings and if needed return the previous settings.