Game will not start an crashes on linux

I am running the game natively through steam and it used to work absolutely fine until a couple of days ago. I have tried veryfing files and reinstalling. I have also tried running compatibility with proton and I keep gettting the same results. The game loads for a bit then sttarts playing hangar music and the screen goes black. After a bit of that an empty error popup appears.

My system specs are as follows:

System:
Kernel: 6.8.10-300.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
v: 2.41-37.fc40
Console: pty pts/1 Distro: Fedora Linux 40 (Workstation Edition)
Machine:
Type: Laptop System: HP product: HP EliteBook 840 G8 Notebook PC v: SBKPF
serial:
Mobo: HP model: 880D v: KBC Version 30.53.00 serial: UEFI: HP
v: T76 Ver. 01.17.01 date: 05/03/2024
Battery:
ID-1: BAT0 charge: 39.7 Wh (99.7%) condition: 39.8/53.2 Wh (74.8%)
volts: 12.5 min: 11.6 model: Hewlett-Packard Primary status: not charging
ID-2: hidpp_battery_1 charge: 54% condition: N/A volts: 3.8 min: N/A
model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse status: discharging
CPU:
Info: quad core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
arch: Tiger Lake rev: 1 cache: L1: 320 KiB L2: 5 MiB L3: 12 MiB
Speed (MHz): avg: 2233 high: 2800 min/max: 400/4700 cores: 1: 2799 2: 2285
3: 1139 4: 2800 5: 2800 6: 2528 7: 2648 8: 872 bogomips: 44851
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Hewlett-Packard
driver: i915 v: kernel arch: Gen-12.1 bus-ID: 00:02.0
Device-2: Chicony HP HD Camera driver: uvcvideo type: USB bus-ID: 3-2:3
Display: server: X.Org v: 1.20.14 with: Xwayland v: 23.2.6 driver: X:
loaded: modesetting unloaded: fbdev,vesa dri: iris gpu: i915 resolution:
1: 2560x1440~60Hz 2: N/A
API: OpenGL v: 4.6 vendor: intel mesa v: 24.0.8 glx-v: 1.4
direct-render: yes renderer: Mesa Intel Xe Graphics (TGL GT2)
API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Hewlett-Packard
driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3
API: ALSA v: k6.8.10-300.fc40.x86_64 status: kernel-api
Server-1: JACK v: 1.9.22 status: off
Server-2: PipeWire v: 1.0.7 status: n/a (root, process)
Network:
Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
IF: wlp0s20f3 state: up mac:
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
bus-ID: 2-2.3:5
IF: enp0s13f0u2u3 state: up speed: 1000 Mbps duplex: full mac:
Bluetooth:
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB
bus-ID: 3-10:7
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: bt-v: 5.2
lmp-v: 11
RAID:
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 bus-ID: 00:0e.0
Drives:
Local Storage: total: 931.51 GiB used: 117.92 GiB (12.7%)
ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P2SSD8 size: 931.51 GiB
temp: 43.9 C
Partition:
ID-1: / size: 387.92 GiB used: 117.5 GiB (30.3%) fs: btrfs
dev: /dev/nvme0n1p5
ID-2: /boot size: 973.4 MiB used: 310.2 MiB (31.9%) fs: ext4
dev: /dev/nvme0n1p4
ID-3: /boot/efi size: 259.5 MiB used: 119.3 MiB (46.0%) fs: vfat
dev: /dev/nvme0n1p2
ID-4: /home size: 387.92 GiB used: 117.5 GiB (30.3%) fs: btrfs
dev: /dev/nvme0n1p5
Swap:
ID-1: swap-1 type: zram size: 8 GiB used: 2.93 GiB (36.6%) dev: /dev/zram0
Sensors:
System Temperatures: cpu: 75.0 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Memory: total: 16 GiB available: 15.38 GiB used: 9.16 GiB (59.5%)
igpu: 64 MiB
Processes: 430 Uptime: 14h 49m Init: systemd target: graphical (5)
Packages: 51 Compilers: N/A Shell: Sudo v: 1.9.15p5 inxi: 3.3.34

It sometimes helps to delete the cache folder.
You might try to run it outside steam. Run the launcer file.

Where does one find the cache for the game? I tried opening the launcher through steam and it worked but I got the same results. Maybe you meant the stand-alone one? I will certainly try that as well.


This is teh error I get With the standalone verison of the game. The crash ID is f8955ef527

It’s inside the WT game folder.
It’s more than 3 years since I used steam, so I don’t remember where “it” keeps the installed games.

Hello @Herojure24,

Could you please submit a bug report on the Gaijin bug reporting platform?

https://community.gaijin.net/issues/p/warthunder

Making sure to provide all required files and information, So .clog, .zip and .dmp files as well as your full system information as you have posted in this thread.