Game runs at extremely low frame rate when window is not in focus

The game has suddenly started limiting the frame rate whenever the game window isn’t in focus. This fps will dropp all the way to maybe around 10fps and this happens regardless of the graphics settings. There is also no gpu control panel settings limiting the framerates. The issues also persist with different graphics drivers as well.
As someone that frequently tabs out to do things on a second monitor while playing it’s getting really annoying. So would appreciate to know if anyone else is having the issues, or ideas what might be causing it or if it’s a game bug.

Edit: OS is WIn11 and system is 8700k, RTX3080, 32Gb ram with game running from a Samsung 970 Evo Plus.

4 Likes

Well, you’re not paying attention to it, why should your computer… /jk.

Other than maybe list what OS and GPU system you are using, I got nothing but jokes.

Yeah forgot to add that so edited the post. OS is Win11 and system is 8700k, RTX3080 and 32Gb of ram with same running from a 970 Emo Plus nvme. Usually running the game in fullscreen windowed but issue persist when running fullscreen. The game has been running perfectly fine otherwise and the issue only appears when the focus isn’t on the window so I have no idea why it’s suddenly limiting it.
Also I do still ofc pay attention to things, which is why the issue is so annoying. Since I’m not minimizing the game just shifting focus to check discord or the browser and things like that.

do you have power saving features enabled?
If you do, it can reduce cpu usage of the apps you arent focused on.

No it’s set to high performance and the gpu is set to prefer maximum performance.

You’re not alone. Today after the update the same happens to me.
When Warthunder is not in focus the game automatically limits itself to 10 FPS.

1 Like

This is happening to me too.

Even on just the logon screen (as the frame counter is shown on there too).

(I’d love to have an FPS limiter when in the hangar, say 30 fps, as there is no need for the gfx card to max out rendering large FPS. But not when I’m in a game and focused on a different window).

1 Like

Sounds like a feature to me.

Same thing is happening to me since the latest update!

Same issue here, Very frustrating
I got rtx 3070ti, ryzen 7 7800x3d and 32gb ram

With the 2.35.0.51 update this is no longer occurring for me

I didn’t see any mention in the release notes, but after starting to read it and it’s “tank … tank… tank… tank…” my eyes start to glaze over :D