Game almost always crashes when playing aircraft (on mac)

Ever since seek and destroy update my game seems to always crash and show this when ever playing as air craft in ground RB and even occurs in air RB but not always. I have deleted and reinstalled the game to see if it fixes the problem but it doesn’t. I have a 2019 mac book pro 16, with i9 8 core 2.3GHz, AMD radeon pro 5500m 4gb, 16gb ram and 1tb ssd and using latest OS. Anyone else experiencing this? And is there a fix or is gaijin even aware of this? Also my settings posted below.


hi, I have the same problem on my macbook pro 2019, but for me game is freezing and in about 30 sec its throw me to log in to system screen, only sometimes i got message “freeze detested” and i every time report it. It also crashes for me when i want to test ride some tanks. Still looking for solution or something from devs.


Same problem since the 2.37.0 update the errors started first the game did not start, I had to restore the files to be able to enter then impossible to play with planes, at the time of starting the flight it freezes and having to restart the computer and it is frustrating and with this minipatch of these days nothing that solves the problems on Mac ¬¬


I am also getting the same issue after the update on my MacBook Model A2141. Game completely freezes up 30 seconds into spawning any aircraft and now when I want to test drive a vehicle. Also tried reinstalling game to no avail. I would love to spend more money during the summer sale, but until this gets resolved I see no reason to.


Happens to me too, 2018 iMac. Intel I5 and extra ram installed. I also have had no damage indicators, on any mode, for the past 5ish months. Not sure why gaijin likes to do fuck all for fixing Mac problems, but it’s getting to a crazy point of too many bugs to play.


I’m having the exact same issue on my 2019 iMac. I have the 3.7 Ghz 6-Core Intel Core i5 running the Radeon Pro 580X 8 GB card with 64 GB of ram. I’m on OS 13.6.6 and the game ran like a DREAM before the update!!! I was playing jets and launching missiles for hours each day… now I can’t even fly a single slow moving airplane without any else around and the game completely locks up my entire computer.

I’ve completely uninstalled everything, reinstalled the entire game, disconnected my second monitor, wiped out all other active running apps or programs and the problem still exists. I can load right into the game, enter the round… get maybe a few minutes into and suddenly everything freezes!!!

Just like Captain_NACL mentioned… I’d be dumping cash into the summer sale right now… but I’m already losing out on my premium account because I can’t even play the game!!!

This is such CRAP!!! Mac users get dumped to the side. This has happened before. When they first introduced air-to-air missiles, the macs would crash and you could only ever play lower tiers. And then it bugged up where the game completely locked up. I was forced to quit the game and just walk away for over a year!

They need to get this addressed!!! Clearly there is an issue strictly related to this update.


Any one have a solution or does gaijin know about this problem?

1 Like

It’s a no to both questions so far. My game also recently started crashing and freezing just playing tanks. Very frustrating when I already have to play with preexisting bugs and then new ones appear that are even more game-ruining.

We can all just sit and wait for them to finally do a half assed address of our problems!

I have the exact same issue on iMac 2016 with 8gb ram and very good specs. Game used to run like a dream except some small graphic issues like the speed of sound cone not rendering and just being black.

that is probably probably because you don’t have enough VRAM and so the game compensates by not really rendering some of those minor things propperly but instead of actually not rendering it, the game puts a black place holder.

alright thanks, to be honest that didn’t really bother me, it was very helpful lol, I could see all the enemies. But the issues right now are way worse and preventing me from playing

No solutions yet!

So far Tanks in arcade seem to be working okay, as long as I don’t try to use a plane. It really seems the issue is directly related to aviation. I haven’t tried ships yet.

But I’ve tried to submit the issue to Gaijin, but who knows if it’s being addressed. UGH!!!

What’s frustrating to me is it seems we’re not getting updates… so it seems our issue isn’t even on the radar. :(

The issue was reported 12 days ago. It’s not even acknowledged yet.

Frustrating for sure. Actually it made me moving on to other games…

surprised much?

Not at all

I can still play ground rb but having fps issues now.

Okay everyone… Here’s what I’ve been able to deduce…

I was finally able to get a screenshot of the lockup versus my computer just doing a soft reboot…
And the code the lockup gave was:

So I looked that up… and of course the recommendation was to update video drivers. Wahoo… yay for solutions for windows for us Mac users. And we all know we can’t just randomly update a single driver that’s integrated into the OS. So I went and ran all the updates I could for OS 13… ran the game. Still had the same problem.

However I did have the option to upgrade to Sonoma… And obviously mac is going to run it’s absolute newest driver software within it’s latest OS… So I upgraded to OS 14.5 Sonoma, ran the game… and flew a RB round… it was flawless!

So of course I was occasionally getting maybe one or two rounds before lockup before… So i still need to push the paces and really stress the game and get into jets, etc. But it does make sense the latest OS would have the most up to date drivers built in for our video cards.

Plus Sonoma apparently has a ‘game mode’ so when you are gaming, it knows to push all cpu/gpu processing into the game. ( I still need to read up more on what all the entails. )

SO… IF you are able to upgrade to Sonoma, try it and report back to here on what happens.
( This all makes sense to me because I lost the ability to play WoW a fear years back when my macbook pro was finally no longer able to upgrade the OS based on the hardware specs. )

Hope this can at least help some of us… and I’m praying the game will still run once I start pushing it harder.

I just realized it’s the same code you initially posted. Let’s hope it can help all of us.


After upgrading my OS and playing all afternoon, flying jets… having a great time again…

Suddenly the game locked up once more! And now once again, I can’t fly ANYTHING without the game locking up!

This is COMPLETE BS!!!

Way to go Gaijin!!! You have completely screwed us over.

1 Like