Framerate hardcapped to 60 only in matches

As stated in the title, since the patch my framerate is capped to 60 whenever I’m in a match/testdrive. In the hangar they are uncapped and >100 (which seems weird to me and probably indicates it’s a problem with the game). I’m using a 144 Hz screen. VSync is off, framerate limiters are off, I clean installed the graphics driver using DDU, the problem doesn’t exist in other games. Has someone experienced the same and maybe found a fix?

System:
Ryzen 5 5600G
RX 6850, driver version 24.2.1
32 GB RAM
Windows 10

EDIT: The problem only exists in fullscreen mode. Switching to “fullscreen window” removed the FPS limit.

Hey there! do you have multiple monitors or playing on a laptop>? I am playing on a laptop and this happens to me sometimes. It turns out that war thunder is trying to use a different display setting and reverts back to my laptop monitors Refresh and frame rate rather than my current 2560*1440 monitor. When this happens after a driver update usually it caps my fps as if its getting confused on which monitor im trying to use.

Hey, thanks for the reply, I should’ve mentioned that. I’m on PC, I use two monitors but I disconnected my second one for troubleshooting. Didn’t change anything.

alright. So it gets full fps in hangar and other places but its only capped at 60fps or so during matches? have you checked your AMD settings for “force” game vsynch or other stuff. I know that sometimes for my nvidia stuff it messes with in game settings. Maybe it is straight up a glitch not sure. I have only had theses situations during a windows update where it resets my stuff for some reason or during a driver or chipset update. But then again war thunder has had many glitches and bugs since the new update so it may be related to that.

Yeah, exactly. I’ve clean installed my driver and checked all settings, it’s not that. Doesn’t happen in other games either, and I’m using a global profile. Just weird.
At least the problem is gone in fullscreen window, but I usually prefer fullscren.

Look for this option in your Adrenalin GPU driver

image

And set it to the maximum refresh rate of your display