FATAL ERROR: Exception

When I was playing warthunder a while ago, my controls suddenly stopped working. When I reset them, it all worked for a couple of seconds, but then my PC crashed. This has never happened before, but I didn´t think much of it. That was until I tried to boot up WT the next day and it just crashed upon startup. I googled the problem, and apparently, I was supposed to remove the cache folder. When that didn´t work, I just completely uninstalled and reinstalled the game. Nothing. Now I´m almost certain that the core problem is something outside of WT, but I still don´t know what. After looking around on the forum, I´ve seen many other people with the same problem, but no answers.

Anything that might help is greatly apreciated

Screenshot 2023-12-14 193705
Screenshot 2023-12-14 193650
Screenshot 2023-12-14 193601

Run cmd as administrator.
Repair commands:
sfc /scannow

Delete all folders of War Thunder everywhere, and reinstall. If you did this already then you don’t have to repeat it.
Update drivers.

That’s all I can think of at this time.

I managed to fix the issue by updating my GeForce driver.

For anyone having the same issue:
First, find out what GPU you have. If it´s a GeForce-based GPU, go to
Download The Latest Official GeForce Drivers,
select your GPU, and download the most recent driver. Worked fine for me, but if it doesn´t, you can uninstall and reinstall warthunder, then it should work

1 Like

Thanks for the update!
Happy holidays :)