Easy Anticheat makes our lives more... difficult!

From the “La Royale” update - probably some week before - logging in from Steam has become impossible. Easy Anticheat gives an “Error 11”. The list of possible solutions is useless.
The only way to log in is through the Launcher, after having reinstalled/repaired Easy Anticheat, but not always: the behavior of this program is erratic and unpredictable!
I keep Windows updated, and the antivirus - McAfee - has been the same for years.

This might be something for the community bug report site: Community Bug Reporting System

But I’ve been getting that error here and there since the update as well what I normally do is just when the game closes, is just attempt to re-launch it through steam.

If you get the error again can you send a screenshot as your error may be different then mine? I just tried to get the error myself but I did not get it.

The error is certainly coming from Easy Anticheat.
Never got it when the game closes.
I have seen that erratically, EA asks for authorization to make changes in my device (the external HDD where everything is installed). If I receive this request, everything will be fine.
Otherwise I have to reinstall/repair and after X attempts, it will work


I get the same error about once a day

What’s weird is that there is not an EasyAnticheat.exe in the directory where it is supposed to be (the one C:\Users\XXXXX\AppData\Roaming\EasyAntiCheat\45, so I can’t give the firewall instruction to let it communicate freely. Apparently EA uses only DLLs???

Only easyanticheat_wow64_x64.eac and easyanticheat_wow64_x64.eac.metadata there

the EAC main executble (as well as the device driver) are by default located in
c:\Program Files (x86)\EasyAntiCheat\ on Windows systems

I’ve got the same issue, even with Anti-virus and Firewall disabled it still gives the same error.

i usually have to restart the game 3 times before it lets me in.