EAC loading failure results in BSOD

For a while now, I’ve noticed that when I’m launching the game if - for any reason - I put the Easy-Anti-Cheat loading process to a background process, say, to check my browser, the load would almost always fail through the Launch Error of WaitForSingleObject failed: 2


This is then followed shortly after by a blue screen with the reasoning being Kernel Security Check Failure. I generally can avoid this by not doing anything until EAC is fully loaded, but sometimes this doesn’t work either (it seems to happen more often when I have YouTube playing, not sure if this is connected).

I’ve contacted EAC about this but they have since closed their support ticket line and asked players to instead report the issues to the game community itself. So here I am. Does anyone know a solution to this (outside of what I have mentioned) and maybe it’s a gameside problem that can be fixed one day?

1 Like

Try uninstalling and re-installing EAC.

It probably just needs a refresh.

Yep, (I think?) I’ve tried that as well as deleting EasyAntiCheat.sys as some people were recommending (on Reddit?) and it appears to work to some extent (I used to have EAC fail all the time, now it only fails when I have it load in the background) but this problem persists, unfortunately.

For me EAC loads, then the EAC/WT window thing just disappears and game never boots, which I assume the software just crashes itself.

Just deleting the EAC Sys File (The driver) wont work.
Completely uninstall Easy Anti Cheat and then manually install it, running “As Administrator” - That worked for someone in a German Windows Forum.

It is not a War Thunder issue, as many players of different games seem to have that problem.
Often times it seems to be an issue where there is some AntiVirus or Driver Manager that tries to install a “More secure” or “Faster” Version of the EAC Driver. But that can lead to this problem. So maybe check that you are not using anything like that.

Gaijin forced EAC on us. It shouldn’t be our job to fix it.

1 Like

How do you go manually installing it? All I’ve seen so far is to run the existing EasyAntiCheat_Setup.exe to uninstall and reinstall it.

I think thats what he meant, although the user in the German forum didn’t specify it and just said it worked.

Thats right, its not your job. And neither Gaijins job. Its the job of EAC lol.

1 Like

Ah okay, I’ll run it now and see if it works!

Update: At this time, it appears to work better than before, no more error if loaded in the background and therefore no BSOD. I’ll keep an eye on it to see if it continues to work as intended.

1 Like