EAC Force closing War Thunder, no fixes seem to work

Game gets forced closed whenever i try to load up War Thunder, this never happened before as it was working on Friday, though when i get back to play, the game loads up the splash screen then the game loading screen, then turns off

Funny thing is when i turn off EAC with the check mark on the launcher, the game works perfectly fine, but when i turn EAC back on, the game refuses to launch, i’ve tried everything, restarting my computer, deleting the .sys file in the EAC folder, giving admin priviliges to everything war thunder and EAC related, i did a src scannow on my PC, i cold rebooted my PC afterwards, i reinstalled the game, i reinstalled EAC through their little menu that shows war thunder as Game 45 (the ID?)

Another thing is when i look through the log it says
[Info] Settings file full path: ‘D:\WarThunder\win32..\EasyAntiCheat\Launcher\Settings64.json’.
[Info] Start. ExecutablePath: ‘D:\WarThunder\win32..\win64\aces.exe’ LaunchParameters: ‘-forcestart -nosteam -add_file_to_report “D:\WarThunder.launcher_log\2023_12_03_21_31_35_16144.txt” -eac_dir …\EasyAntiCheat’ WorkingDirectory: ‘’.
[Info] Finished window initialization.
[Info] [LauncherProgress] 0%.

Problem is it says Launcher Progress 0% allll the way down until it says this

[Info] [LauncherProgress] 100%.
[Info] [LauncherFinished] EACAsyncResult: 0 Message: ‘Easy Anti-Cheat successfully loaded in-game’.
[Info] Unloading the EasyAntiCheat library.
[Info] Destroying windows.
[Info] Exit.

I’m not entirely sure what to do at the moment…

2 Likes

I have the same issue. 1/2/2024 the game was working. 1/4/2024 EAC must be the issue. Same as you. If I launch through steam and let EAC launch with it, I get to the hangar shortly followed by a force close, no crash error. If I launch through the War Thunder launcher, disabling EAC, the game stays at the menu indefinitely, no force close.

Did you ever figure out or find a solution? Can’t find a way to play the game.

Similar problem:

Try logging in to your Gaijin account and changing your password.

I’ve overheard discussions about their accounts being changed for no apparent reason and make sure your locale settings are right.

EAC was updated to force Windows 10/11 only in which some cases has caused issues for players such as this. Because War Thunder is using the latest EAC and not their own security, players have to suffer issues caused by third-party applications. This has happened in other games that uses EAC as well.

Gaijin also needs to change their specifications for the game based on whether players are using EAC or not as Arcade Battles (AB) are accessible without EAC while Realistic Battles (RB) & Simulator Battles (SB) require EAC to be turned on.

I honestly do not see the reasoning for EAC (Third-Party Application) to determine what mode one is allowed to play.

3 Likes

Just began experiencing the exact same issue as of today. Extremely frustrating, cleared cache, reinstalled EAC, uninstalled and reinstalled WT, blah blah blah, the only thing that stops the crashes is launching the game with the launcher and EAC disabled. I rolled back my Geforce driver to one from mid January since I knew it was working for me at the time, but no dice. Installed the latest Visual Studio redistributables like EAC support says to do, and stll nothing. On Windows 11 build 22631.3085

UPDATE EDIT: I mentioned that I rolled back my NVIDIA gpu driver, well I decided to re-install the latest (551.23 at the time of writing) driver using GeForce experience, and I checked the “Clean Install” box when doing so and… now the game is working again, I was just able to complete an entire match.

UPDATE 2: I closed the game and reopened it, and now the game is immediately closing after the EAC screen, even faster than before. Darn.

1 Like

After I last update this post, I restarted my computer, and bafflingly enough, the game started working again. I didn’t know if it was a fluke or not, so I never gave an update.

Well, as of yesterday (April 13th 2024), the exact same thing started happening again, and I have very little clue as to why (the only thing I did the night before was remote desktop into my computer from my phone and launch a GPU powered AI Image generating program, but I doubt that other users are doing that too). I did everything I could think of to work around the issue:

  • There was an NVIDIA driver update available, so I clean installed it with GeForce experience, no change
  • I have the game installed via Steam, I verified files, no change
  • I opened launcher.exe from the game’s install folder, this actually launched the game and I was able to play. I was also able to open the game again normally through Steam, but after a reboot, this stopped working entirely; even if I opened the game via the launcher, it would still close
  • I did a sanity check, I disabled EAC via the launcher, sure enough, game launches and does not close. Turning it back on causes the game to close once, sometimes immedeately after the EAC screen (game doesn’t go full screen), sometimes right before/right as the game is connecting to the servers, sometimes right after the game connects to the servers, and on occasion, after a few seconds after loading into the hanger. Very variable results.
  • I uninstalled and reinstalled EAC multiple times, using multiple methods and differing levels of thoroughness. This would either give me a crash after hangar load, or an immediate crash after EAC splash
  • And yes, Windows does register this as a crash, I was using Procmon out of desperation (an official Microsoft SysInternals tool for non-invasive process monitoring), every time the game would close, the windows error reporting suite would kick in in the background (never in the foreground). This oddly enough is never mentioned in the Windows Event Viewer

NOW, as of right this second, I begrudgingly rebooted into safe mode on Windows 11, used the latest DDU, downloaded the latest NVIDIA driver (552.12 as of writing), rebooted into regular Windows 11, clean installed both the driver and NVIDIA Broadcast (1.4.0.29) , and after getting my settings back to the way I like them (shadow play preferences, hotkeys, Unlimited shader cache settings in NVIDIA Control Panel, 2nd monitor positioning and rotation, etc.), the game launched, logged in, and I am currently sitting in the hanger, no crash yet. Last time this happened, after I closed the game it no longer worked.

So if you’re desperate like me and you have premium time counting down and boosters about to expire, try this to get the game to open once.

UPDATE: Sure enough, after I closed the game, I was not able to open it again without it closing once reaching the hanger. I rebooted my pc, it began working again, closed the game again, and now it closes at the hanger again. I rebooted once more, and now the game just closes when it reaches the hanger. I already have a bug report in for a related issue (regarding the game crashing while flying planes), and I was lucky enough for it to be acknowledged, but it took a lot of back and forth with the moderators there for them to realize it wasn’t just a me issue.

I was about to submit a bug report, but it looks like this has been reported quite a few times in the past, and the general consensus is that, as @TT33a’s screenshot shows, that the moderators will say that this is an EAC issue, but EAC says to contact the game developers (and in fact, they have redesigned their website, and the support page only tells you how to collect logs “for whoever is helping you”. No way to put in a ticket [unless its a ban appeal], no support email address, no support phone number.) The only bug report that had a resolution was when the submitter reinstalled Windows, the issue stopped. I’m not about to try that for just War Thunder, but if someone is more desperate than I am, then I guess give it a shot. I have seen two instances of people saying reinstalling Windows fixed it for them, once on the forums, and once on the official issue tracker.

Overall extremely frustrating as someone with premium time and boosters in their inventory.

Ok this will be my final response unless I find a permanent fix. If you found this thread because you’re having the same issue, I have some extremely unfortunate news: This is not something Gaijin can fix, probably ever. This is 100% an Easy Anti-Cheat issue. I tested Halo: MCC and VR Chat on Steam, the first uses the same type of EAC as War Thunder, and the second uses the Epic Online Services version of EAC. Both games had the exact same issue as War Thunder, i.e. the game gets to a certain point (login screens mostly) and then force closes with no message.

For what it’s worth, for the past two days I have had zero issues. So if you’re experiencing this, simply waiting might just fix the issue. Blame Epic games for their crappy kernel level anti-cheat.

Hi Bro,

I faced the same problem with you after I update the Warthunder on 27th May. I had restall the game twice and it didn’t work. I tried everything I can but there are useless. I also contacted with Gaijin service but they could do nothing. I don’t know how it happened. I played this game for 8 years, I don’t want to leave just because of this suck issue. I don’t know why Gaijin choose the worst Anti-cheat software(maybe it is the cheapest). It makes me cannot play my favorite game.

Reinstalling isn’t the true method of fixing any of this. Finding the reason why it’s failing and actually fixing that is.

About a month or three ago I had the same issue. Eventually I turned off EAC and WT worked fine, but of course only in arcade mode(s). Two days ago I turned it back on out of curiosity and EAC WORKED - including realistic mode. I don’t know if this will help, if at all, but there may well be light at the end of the tunnel.