"connecting to server" no progress on dev server

Just woke up earlier to see the dev server live, been wanting to play it for the past 20 minutes, if I don’t oh well, however, it’s been stuck “on connecting” I log in through steam on the Gaijin launcher, and still. Wont log in, no I don’t have a Gaijin account, I mostly use steam for everything. It’s worked before with the aim120 dev server and last years dev servers, not sure why it’s being fucky now.

same brother stuck6 o9n that screen for 40 min

[Censored], glad I’m not the only one, shit said my steam login was invalid as well but it works on the normal warthunder. Just wanna figure this shit out before I work this week, today and tmr are my only free days rofl.

This is a known issue.

1 Like

Known issue alright, but how do we solve it? Im pretty sure streamers like Defyn are already on?
Please help i really wanna play this and ive got work soon please look forward to this

I got on you just have to keep trying

1 Like

As 64_bit said, you gotta keep trying. The issue appears to be resolved as well.

Oh its solved? So do i just wait when it says connecting? Thanks

1 Like

It’s working now, I’m just impatient and I go straight to some sort of forum to ask lol, thanks for the help!

1 Like

Okay but how do we progress here? because no89body seems to9 be in the queue? my first time on dev server so89rry.
please help if po9ssible