Can't get rid of screen tearing and FPS problem on a high-end PC

Hi guys,

First of all I’m sorry for wasting your time (and also for my bad English), but I’m having a technical problem. I have very good PC and a monitor with a resolution of 2560x1440 170hz (g-sync). I have been struggling with the problem of screen tearing and FPS drops for a long time, even though my computer can easily run the game at maximum graphics settings (TAA + 4x SSAA). The case looks like this:

When I have v-sync turned off in the game, I can easily reach 200+fps with drops to about 190 fps. Of course, the problem then is screen tearing, which I hate.

When I turn on adaptive v-sync + g-sync in the game, my frames stay at 170 fps, but often drop to even 130 fps. Can someone explain to me, why the game runs stable at 200-190 fps when I turn off v-sync, but can’t maintain 170, 165 or even 144 fps when it’s on? (I was trying to adjust the refresh rate to 170, 165 and 144, but i’m always getting small drops with causes a screen tearing.

I would really like to get rid of the screen tearing effect, and be able to enjoy a smooth game with stable fps. I have tried many ways, but screen tearing still happens sooner or later. Anyone have a good solution?

Once again, sorry for wasting Your time and thank you for your help.

My PC:

  • RTX 4090
  • i9-13900K
  • 32 GB RAM

Because vsync in WT is bugged. Fullscreen is also bugged if you have multiple languages.
You can try to improve it by forcing vsync in nvidia settings. You can also try to enable Nvidia Reflex, it should limit fps at 138ish which enough to prevent screen tearing.

1 Like

Thanks for the reply. I tried settings like: v-sync (control panel) and cap fps to 141, but even then fps drops occur and I have screen tearing. The problem is that without v-sync the game maintains 200-190 fps, but when I set adaptive or normal v-sync then frames cannot be stable even at 144.

Best results to me at the moment (for perfect quality and no tearing was):

Turn on DSR (1.78), then turn on v-sync in control panel, DLSS quality and game without SSA. Only that solution was helpful, but how much troubles does it take, instead of enjoying the game.

Every game I launch keeps frames at a stable level with v-sync, but War Thunder does not. That’s the problem. I normally run games at 144 frames with v-sync (no screen tearing, fps drops) but in War Thunder v-sync is unstable and the game cannot maintain 144 fps.

Have you tried to enable reflex? Maybe you won’t have tearing with it and without dlss so the quality will be a little higher / less blurry.
I personally have similar configuration and use SSAA with manual configuration (1.75 instead of 2) and I think reflex was the thing that prevented tearing / random vsync stuff.

I did not try. Thanks brother. I’ll let you know if it helped.

Now it’s a little better. Thank you for your advice. Unfortunately, when reflex and v-sync are turned on, screen tearing still occurs sometimes, because FPS drops from 140-138 to 120, etc. I do not understand this, really. When I just turn off v-sync the game reaches 200 fps. Huh. I guess this game simply can’t maintain stable frames with v-sync.

I had this issue as well - I managed to fix it by manually frame limiting on the nvidia control panel.

Average FPS for me in WT was about 190 in GRB and 170 in GRB. Limited it down to a 100 (75Hz) screen. This seems to have fixed the issue for me.

nVidia Control Panel > Manage 3D settings > Program Settings > War Thunder (aces.exe)

You set your preferred monitor to primary, then when you run fullscreen apps it ends up on the monitor you want it on.

It’s not the game that does this.

Thanks, I tried it - cap fps to 141 and the monitor was at 144 hz. Do you have v-sync turned on? If I turn on v-sync, the frames will be unstable anyway. If I turn it off, they will be stable, but there comes a tearing.

Game becomes smoother and screen tearing is reduced when:

I will enable v-sync in the Nvidia control panel, g-sync on and enable reflex. But what is funny thing - fps can drop from 138 to 115-120.

I don’t understand one thing. Why can’t it maintain a stable 138 frames, when without v-sync it reaches over 200? I understand that there are damage effects, fire, smoke, but the 4090 and 13900k should be able to deal with it without any problems. Haha, just idk.

if you are running a 144hz screen you gonna need to trial and error to find the sweet spot. Do not touch the VSYNC option. That is one of the buggiest things in WT. See the screenshot

CC @maksyyo

EDIT : This is for my specs specific, you will need to play with it for a bit and check it over a few battles. Need to restart your game each time.

I have -



1 Like

Thanks. I have V-sync enabled in the Nvidia control panel. I’ll have to turn it off and try. Thank you for your help, I will try to fix it tomorrow, but this problem irritates me. Thanks!

To clarify: you have 75hz monitor and cap fps to 100, right? V-sync and reflex off?

More fps than monitor won’t affect you a screen tearing?

1 Like

For me personally : 75Hz Screen, VSYNC OFF and capped to 100FPS - correct

1 Like

Oke, that’s weird haha. So maybe I will try to cap fps higher than my refresh rate. That’s my another hope man, cause everytime fps was higher than refresh rate - it was causing a tearing

Ye I went from 75Hz up by 5 till I stopped seeing issue. Should’ve mentioned that - sorry

1 Like

Another important question. Do you use all maxed settings like SSAA x4 and TAA? Thanks!

1 Like

I clicked “movie” and let her rip

I have only one monitor.
Also no, fullscreen in WT is affected by language panel somehow.

If you use SSAA - you pretty much don’t need TAA, it makes picture blurry. Just SSAA is enough for aliasing.

Understood. Thank you!