Black Screen whilst playing

After the update I’ve been getting a black screen 2-3 minutes into a game. This has been happening none stop & the only way to get out of it is turning my computer off by the main power.

Has anyone else been experiencing this & would you have any advice on how to fix this so I can actually play War Thunder :D

Can you clarify, do you still get sound playing, and keyboard lights (e.g. capslock , numlock) changing, or do you mean everything has completely locked up?

Check/update video drivers is always the standard answer too – not sure if you’ve tried that?

What system are you on? (e.g. Windows, mac, linux, and geforce/radeon/other gfx card?)

Yes I still hear the sound & keyboard is on however my monitor loses signal after 5-10 seconds.

I updated my drivers I’m on the new version - Nvidia Geforce graphics card

Don’t have any issues regarding other games just WT after the update.

One thing to try (if you haven’t already) is to use the Studio Driver version rather than the Game Ready version (for the geforce drivers). It is meant to be more stable and reliable.

If it’s just War Thunder then you can also create a support ticket at: Community Bug Reporting System

Ok thanks I will try

I have a feeling it won’t work as I was on an older driver version when it started happening, that’s why I tried updating them to see if that would help

Still no fix unfortunelty :/

Do you play in Fullscreen or Fullscreen Window? (Maybe try Fullscreen Window if you’re using just Fullscreen)

And if you’re up to trying more stuff… (this just more my curiosity than anything, so ok if you don’t want to).
It would be interesting to see what happens if you play in Window mode with a lower resolution. In the launcher set the game resolution to something less than your screen, then set Window mode. You should then get Warthunder in a regular window and still see your desktop stuff around it. Then see if the black screen appears just for the Warthunder window, or if it’s your whole screen as well.

(Also, rather than power off at mains you can probably Alt-Tab out of the game and then close it down from Windows – not sure if you’ve tried that).

There looks to be many various complaints on the forum and support site about graphics going strange since the update.

I’m also getting some slight stuttering. I have my setup limited at 60fps and have headroom on the gfx card (according to MSI afterburner) but yet it will still occasionally start dropping down to 55 or so and stutter. When it does stutter, Afterburner isn’t showing it’s hitting limits. I’m not sure exactly when it started, but fairly recent.

I play fullscreen I can try fullscreen windowed when I get home.

I’ve tried everything I can’t Alt + Tab out of the game.

Update:

Have tried Fullscreen borderless & bordeless still no luck.
Have tried other things like setting the priority to high in task manager for WT.

I’m starting to think there is no fix