Game Will not Load after Update on MacOS

Game Will not Load after Update on MacOS

No idea why it was working fine until yesterday then today I got an update and the game won’t load, the app starts but then it stops responding the menu bar says War Thunder but doesn’t go full screen nothing shows up.

I’m on the current latest macOS Ventura 13.6 it’s an M1 Max MacBook Pro 64GB Ram 2TB SSD

Similar issue, but I’m on Windows.
The launcher will not open at all and launching by the .exe gives a “Freeze detected” error.
Was working fine on Friday, I didn’t try to play yesterday and now its completely screwed.


It started working for a while now after the update I got today stopped working again i’m now on macOS Sonoma but still latest everything

1 Like

And whats with the update downloader… speeds up and down like mad. Sits at 6MB/m then drops down to 0. Have to restart the launcher to get it to download again… and then you risk the horror of “Anayzing files” taking 10 minutes to do god knows what.
I’m starting to think they don’t want me to play…

I have the same issue on windows… I can play once “freeze detected” pops up by tabbing in to the game BUT it is VERY VERY VERY slow once in the game… Game maxes out CPU… my laptop is quite old, spec is:

|Processor|Intel(R) Core™ i5-5200U CPU @ 2.20GHz 2.20 GHz|
|Installed RAM|8.00 GB|
NVIDA GEFORCE graphics card

from what I can tell everything is OK . I did get a coupe of games after the update but then it started like this. Have reinstalled the game but that made no difference

Literally just had to wait a little longer and it showed up as well

1 Like

I can sometimes get in once that pops up by tabbing to the game but performance once in is shocking… not sure if it is my old laptop (worked ok until a few sessions after teh latest update) or the game… or windows driver somewhere conflicting…

sometimes I get a blue screen of death which I think is triggered by easy anti cheat

it was working before I updated to Sonoma

the launcher just updated but it fixed nothing

Updated to Sonoma today and war thunder won’t launch anymore just sits in dock and says Not responding

Gaijin is not going to fix this anytime soon, they prefer to fix cosmetic things in the face of system error. Testing using the method I do to play, is the only way to get into the game so far.

Post this as fixing the crash:

Same issue, game was fine yesterday, now I can’t even load up the game. I can open the launcher and select ‘PLAY’ but the game just crashes.

1 Like

You have to consider that the game on Mac is slow to load, I imagine you should get “WT not responding” when you apply Force quit? Try using from the launcher instead of steam to see what is failing.

Is it working for u now? I just updated to Sonoma today and the game keeps on crashing

1 Like

I am getting ‘OS Error 4294956469’. I updated to Sonoma about a week ago and I have uninstalled and Reinstalled War Thunder two times and steam just doesn’t let me boot it however this wasn’t happening before.

SAME for me!

same thing is happening to me, i got macos sonoma on m1 pro chip so i dont know whats happening but when i force quit war thunder i can see it wasnt responding cuz it hanged

1 Like

same problem on intel mac pro 2017

its just freezes and mac shuts down

so its still not fixed after several months