Jump to content

FPS cap in hangar is creating flicker of monitor


Hello there! :)

 

I'm having quite the unique issue in that when going back to the hangar after a few matches, the monitor of mine starts to flicker while the FPS are being capped to 60FPS (only in hangar).
If I jump right into a new match or something else, the screen goes back to normal. This only happens in Linux, not in Windows (dual boot), with the same drivers and hardware.

I've already tried different monitors (2 different LG 27GL650F, MSI MAG274QRF-QD).
The issue is only apparent in War Thunder and only in the hangar (but will spread out to battles after some time).

Restarting the game fixes it for some time.

 

- Adaptive Sync is activated system wide

- MangoHud is issues a system wide 143 FPS cap.

 

In clear steps:

1. Start War Thunder

2. Go into a match (Air or Tank is irrelevant)

3. Go back to hangar

Repeat 2. and 3. a few times

2022_02_06_12_23_02__10199.clog inxi.txt

2022_02_06_11_26_47__5444.clog

Edited by Detrophy

Share this post


Link to post
Share on other sites

  • Technical Moderator

Hello, @Detrophy,

 

Do you get the same if you disable the MangoHud FPS cap? As your GPU is AMD and monitors are G-Sync I'm assuming you have confirmed Adaptive Sync works correctly on Linux in other games/benchmarks?

Share this post


Link to post
Share on other sites

Hi there,

 

https://de.msi.com/Monitor/Optix-MAG274QRF-QD/Specification  <-- There you can look up the exact specification of the monitors. It's G-Sync compatible and fully capable of Freesync (VESA Adaptive Sync) as the other monitors are. Yes, the feature is working flawlessly in every game, even in War Thunder, also in games with low FPS or near 60 FPS are flawless. No flicker whatsoever.

I will create a video of it with my smartphone later on (with MangoHud off).

It seems to be fixed with the removal of MangoHud in WarThunder, but creates another issue, excessive heat output not necessary due to crazy high framerates.

 

I personally would flag the issue with MangoHud (only apprearing in WT) and the flickering as a bug in the game.

Screenshot_20220207_222538.png

Edited by Detrophy
Added additional info

Share this post


Link to post
Share on other sites

  • Technical Moderator

@Detrophy,

 

Right, I missed Freesync when I was looking at that monitors specs. So if I'm understanding you correctly the flickering only happens with the MangoHud FPS cap turned on and in the WT hanger? In which case it sounds like the MangoHud FPS cap is interfering with the in game FPS cap in the hanger. What FPS do you get in WT matches with the MangoHud FPS cap turned off? Also what GPU temperature are you getting?

Share this post


Link to post
Share on other sites

Depending on the scene or situation I'm in, the FPS are way over 200.

My system is completely custom water cooled and the heat itself is not a problem (~60°C on hotspot), but unnecessary.

 

Yes, the flickering only appears in the hangar when the cap is turned on.

 

EDIT:

I just saw a slight flicker in hangar, without MangoHud loaded up.

Edited by Detrophy

Share this post


Link to post
Share on other sites

  • Technical Moderator

@Detrophy,

 

Right, Where exactly did you enable Adaptive Sync system wide?

Share this post


Link to post
Share on other sites

  • Technical Moderator

@Detrophy,

 

Right, Thank you, If you enabled vsync in WT, What FPS does it run at while in a test drive or matches? And do you still get the flickering? Also, I'm assuming you have seen this page from AMD?

 

https://www.amd.com/en/support/kb/faq/gpu-754

Share this post


Link to post
Share on other sites

Hey @apemax,

 

yeah, I've seen that page but it won't apply to my system. I'm using the mesa open source driver, which is the defacto standard for everything else than Ubuntu (or Debian derivates) and its flavors.

Also, this page is horrendously outdated, as it not only not contains any newer hardware, it also shows an outdated version of Ubuntu and games (cmon, Witcher 2?)

 

While VSync is activated, the FPS in hangar is then capped at 165 (as the monitors max native refresh rate is), not 60 anymore.

The maximum FPS in game is then capped at 165, but the flickering still persists (only when cap is reached).

Share this post


Link to post
Share on other sites

  • Technical Moderator

@Detrophy,

 

Right, So you get the same flickering with VSync enabled as you did with the MangoHud FPS cap enabled? Also, Just to make sure, Could you please test this with Adaptive Sync disabled and VSync enabled? Just so we can narrow it down to Adaptive Sync?

Share this post


Link to post
Share on other sites

  • Technical Moderator

@Detrophy,

 

Right, Could you please upload a .clog file from a session in which Adaptive sync is enabled, VSync is enabled, The MangoHud FPS cap is disabled and you get the screen flickering?

  • Like 1

Share this post


Link to post
Share on other sites

  • 1 month later...
  • Technical Moderator

No more response from OP, Report closed.

 

Locked and moved to already reported and solved issues.

Share this post


Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...