Jump to content

Rptd: [2.7.0.43] Research Tree - Minor Graphical Bug


Encountered this today, I have experienced this in the past but this occurs very rarely.

It is to my understanding the BMP-3 is not a part of the Russian Airforce.

image.thumb.png.63e4d97f8b5b2ffa2591d7fe

The description is as follows:

A vehicle from a research tree (a tank in this case) is appearing in a research tree of separate vehicles (aircraft in this case).

 

I am unable to reproduce the effect above consistently, but a description of what I did prior to noticing this is as follows:

1. I booted up the game for the first time today, immediately after today's patch.

2. I selected between two lineups named "Aircraft High" and "Tank RB (tanks)"

3. When the lineup "Aircraft High" was selected, the BMP-3 was in the first crew slot, the IL-28SH was in the fifth slot.

4. I sent the first crew slot to a holiday

5. I opened the research tree on the aircraft tab and noticed the bug

6. Selecting "Choose a crew" on the BMP-3 in the aircraft tab works as normal.

DxDiag.txt

2021_06_11_11_16_30__30872.clog

 

The bug seems to dissipate after switching to a new research tree. For this reason I put "Minor Bug" in the title

medal medal medal

Share this post


Link to post
Share on other sites

Do you have any player modifications installed?

 

Mine shows it all correctly.

shot 2021.06.16 13.04.47.jpg

Share this post


Link to post
Share on other sites

I do not have any modifications of any kind, my game should be in the same format as all others.

this is something I've noticed for the past year or so, but it only occurs extremely rarely. I believe it has happened to other vehicles other than the BMP-3, but it is the most common case.

medal medal medal

Share this post


Link to post
Share on other sites

 

On 19/06/2021 at 17:52, The_one_guy said:

I do not have any modifications of any kind, my game should be in the same format as all others.

this is something I've noticed for the past year or so, but it only occurs extremely rarely. I believe it has happened to other vehicles other than the BMP-3, but it is the most common case.

Thanks for the information

I notice that your graphics driver is out of date.    The current NVIDIA Driver Version is: 27.21.14.6677

Card name: NVIDIA GeForce GTX 1050  Driver Version: 27.21.14.6089  Driver Date/Size: 12/10/2020 8:00:00 PM, 1049800 bytes

Can you update the driver and then do the following:

1. Ensure the game is not running.

2. Using File Explorer/This PC - navigate to the War Thunder directory on your computer system.

3. Locate the 'cache' sub directory in the War Thunder directory and delete it.

4. Restart War Thunder via the game Launcher.

5. Click the spanner icon in top right of screen which will open the second launcher screen.

6. Click the Check files button located on the left hand side of screen in about the middle of the page and allow game to check files and update.

7. Enter Game and re-check for issue.


 

 

Share this post


Link to post
Share on other sites

Thanks for letting me know my drivers were out of date.

I followed your steps and did not see the bug, however, it could be that I was unable to trigger the bug as it is extremely rare. I likely only experience it once a month.

medal medal medal

Share this post


Link to post
Share on other sites

16 hours ago, The_one_guy said:

I followed your steps and did not see the bug, however, it could be that I was unable to trigger the bug as it is extremely rare. I likely only experience it once a month.

Thanks,  I will close this report as I cannot replicate this issue.  If it happens again then please PM me and I can re-activate this report.

 

Cheers

  • Like 1

Share this post


Link to post
Share on other sites

  • 1 month later...

Post summarized from DMs with KnightoftheAbyss

The bug originally related to this post occurred again at a later date on 8-17-2021.

This time it was the T-80B that appeared in the aircraft tech tree.

 

After launching the game for the first time that day, I noticed a modification was researched for that particular vehicle. Likely due to getting research points after a game had ended, after I had already closed warthunder.

The modification screen auto-opened and I selected the next item to research and closed the modification screen.

After closing the screen I selected the Yak-38M to be in my line-up, previously the T-80B was the only vehicle in the line-up,

then I opened the research panel, which opened on the ground vehicles tab.

I then switched to aircraft research and noticed the bug.

warthunder_8-17-2021_graphic_bug.thumb.P

 

 

I have a theory on what the issue may be caused by.

I noticed that when I relaunched the game (after I got a clog just in case). That when I put the T-80B back in my line-up, after I had removed it as can be seen in the image, that the modification screen immediately popped up for the T-80B without being prompted to.

 

My theory is this: When gaining enough research points after a battle to research a modification after warthunder has been closed, the game will attempt to open the modification screen upon launching the game. However, for whatever reason (perhaps maybe two or more games completed without without the player being online), the modification screen opens more than once.

This would confuse the game since if you closed the modification screen, the game would think it is still open.

Hence, why the vehicle appears in the wrong research tree, because the game still thinks I have that tank selected and have its modifications tab open.

 

This would explain why the bug is rare since the conditions are difficult to meet, and would explain the mannerisms of the game after the bug is no longer showing.

 

This is just a theory. However, this is a common bug found in games with menu screens and is a common tool used for exploits.

 

Attached is the relevant clog, and DxDiag.txt

2021_08_17_19_59_42__23712.clog

DxDiag.txt

 

Edited by The_one_guy
medal medal medal

Share this post


Link to post
Share on other sites

Thanks for the information.  I will try to replicate it and get back to you shortly.

 

Cheers

  • Like 1

Share this post


Link to post
Share on other sites

  • 3 weeks later...

I am sorry for the delay.  I need to wait until one of my vehicles is finishing to test this.

 

So far, I could not replicate it.   I should be able to make another try at this shortly.

Share this post


Link to post
Share on other sites

On 19/08/2021 at 11:15, The_one_guy said:

My theory is this: When gaining enough research points after a battle to research a modification after warthunder has been closed, the game will attempt to open the modification screen upon launching the game. However, for whatever reason (perhaps maybe two or more games completed without without the player being online), the modification screen opens more than once.

This would confuse the game since if you closed the modification screen, the game would think it is still open.

Hi,

  I am getting close to being able to test this again.  I just want to make sure I have this correct in my mind.  It is indeed correct that if there is outstanding modification points to be allocated after the completion of a modification in the game, a window will present for this to occur.   Two or more games, however could be problematic.  As there is a function that prohibits 'stacking' of games.  Game A must complete before Game B, or the RP from A will not be applied.  IF Game A finishes BEFORE Game B finishes, then there could indeed be RP available to be applied to modifications.

 

I need to be sure I have your process correct.  After the modification window presented when you restarted the game, you applied the new modification(purchased it for SL) and then applied the remaining RP points to the next modification.  Did you have multiple outstanding modifications unlocked and needed to be purchased?  Or just the one mod?

On 19/08/2021 at 11:15, The_one_guy said:

After closing the screen I selected the Yak-38M to be in my line-up, previously the T-80B was the only vehicle in the line-up,

then I opened the research panel, which opened on the ground vehicles tab.

I then switched to aircraft research and noticed the bug.

This is the part I am a bit confused over.  

Did you close the modification screen after applying the SL and purchasing the modification unlocked for the T-80B, then opened the Tech tree, selected Air Research and then the Yak-38M to replace the T-80B in the Preset?  Or did you select the Yak-38M from the Preset vehicle menu?

ie: Using this option?

shot 2021.09.21 08.52.03.jpg

 

Did the vehicle with the modification need to be repaired?

 

I have been unable to replicate this again.   

shot 2021.09.21 16.02.07.jpg

I quit the game without action at this point and restarted.

shot 2021.09.21 16.04.42.jpg

All I got was the window and option to repair and apply the modification on restart.

It never gave me the option which you indicate.  I will report it as it is.

 

Thanks

  • Like 1

Share this post


Link to post
Share on other sites

On 20/09/2021 at 18:52, KnightoftheAbyss said:

I need to be sure I have your process correct.  After the modification window presented when you restarted the game, you applied the new modification(purchased it for SL) and then applied the remaining RP points to the next modification.  Did you have multiple outstanding modifications unlocked and needed to be purchased?  Or just the one mod?

 

As far as I remember, it was only just the one mod. As I have very little on the T-80B researched I would have likely been grinding out essential items like apfsds.

 

On 20/09/2021 at 18:52, KnightoftheAbyss said:

This is the part I am a bit confused over.  

Did you close the modification screen after applying the SL and purchasing the modification unlocked for the T-80B, then opened the Tech tree, selected Air Research and then the Yak-38M to replace the T-80B in the Preset?  Or did you select the Yak-38M from the Preset vehicle menu?

 

So to describe a bit better at least from memory. The T-80B was in crew slot 3 when I logged out. So when I logged back in, the T-80B was the only vehicle I had in my lineup in crew slot 3. Crew slots 1-2,4-5 were all empty. I then selected the Yak-38M from the preset menu into crew slot 5 before going to the air research screen. 

 

 

On 20/09/2021 at 18:52, KnightoftheAbyss said:

Did the vehicle with the modification need to be repaired?

 

At this time I had auto-repair enabled. So it would have repaired after battle. I did not need to repair it.

 

On 20/09/2021 at 18:52, KnightoftheAbyss said:

 

I have been unable to replicate this again.   

shot 2021.09.21 16.02.07.jpg

I quit the game without action at this point and restarted.

All I got was the window and option to repair and apply the modification on restart.

It never gave me the option which you indicate.  I will report it as it is.

 

So in seeing this screenshot this is not how the bug manifested for me. This screenshot shows that you were online during the end of battle report. Whereas for me, I was offline during 2 end of battle reports. To explain further, I only had my T-80B in my lineup so I started a game, died near instantly and left early. Then I went to a new game and also died instantly. Frustrated, I then logged out before either of these games were over.

 

Thanks for taking the time with the bug report, I was honestly expecting for this to be shelved and never seen again.

medal medal medal

Share this post


Link to post
Share on other sites

17 hours ago, The_one_guy said:

Thanks for taking the time with the bug report, I was honestly expecting for this to be shelved and never seen again.

That is what we are here for.  This does appear to be a genuine issue.  It is just replicating it that is proving difficult.

 

Cheers

Share this post


Link to post
Share on other sites

17 hours ago, The_one_guy said:

This screenshot shows that you were online during the end of battle report.

Yes.  But I quit out before applying the mod etc.

Share this post


Link to post
Share on other sites

Hi
  Thank you for your interest and help improving the game.  

Your information has been forwarded to the Developers for their consideration.  

If there is anything further regarding this report a Technical Moderator will contact you.

Thank you again for your support.
 

Share this post


Link to post
Share on other sites

  • KnightoftheAbyss changed the title to Rptd: [2.7.0.43] Research Tree - Minor Graphical Bug
Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...