Jump to content

Fix for view distortion/barreling in Windows Mixed Reality


Myself and a few users have experienced view distortion issues in VR. I use an HP Reverb G2, and all of the other users I know of that reported this issue also used a Reverb G2, so I don't know if this applies to other VR headsets. Some users described the issue as "barreling," but what happens is everything will appear at the wrong visual distance, or the IPD is off. Overall, it hurts to look at.

 

A while ago I created a bug report thread, but the thread has been locked since I was not able to solve or recreate the issue until now:

I've managed to recreate and fix this issue on my system, and I've gathered some solutions that other users reported, since it seems there is more than one cause.

 

Here is a list of causes and solutions I have found:

 

  1. Windows Mixed Reality settings:
    • image.thumb.png.45bcc69abf27931abe97c484
      1. Settings > Mixed Reality > Headset Display > Experience options. Selecting the "Optimize for performance" option caused this issue for me. "Let Windows Decide" did not cause this issue on my system, but if that doesn't work, try selecting "Best visual quality."
      2. Settings > Mixed Reality > Headset Display > Resolution. This setting did not make a difference on my system, but it may be worth setting the resolution to 4320x2160 if nothing else works.
      3. Settings > Mixed Reality > Headset Display > Frame rate. One user reported, and I have confirmed, that setting the frame rate to 60 hz caused view distortion in VR, but changing it back to 90 Hz fixed it.
  2. OpenXR Developer Tools for Windows Mixed Reality:
    • image.thumb.png.766e4333a7e9bff6ef5a92f8
      • OpenXR Developer Tools for Windows Mixed Reality is a utility that can be downloaded from the Windows Store. This shouldn't be the cause unless you have already downloaded and installed this tool, but it may be worth trying if nothing else works.
      • One user reported that enabling custom render scale and changing it caused the view distortion. disabling the custom render scale or setting it to 100% should solve this issue.

 

Please reply if you have anything to add. If you have a different WMR headset, I would appreciate it if you could test this as well, since I don't know if this applies to any other headsets.

Share this post


Link to post
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...