Jump to content

Foreward: This involves some steps if not performed correctly can mess up your install on some distributions. This solution has worked for me and 1 other person, possibly another. If it doesn't work for you, please post saying as such.

So basically in my previous post I manage to track down the issue to a known problem with Nvidia's implementation of Vulkan in their drivers. It appears as though on the 460 driver branch they have done a lot to improve/fix the implementation of Vulkan which has fixed this error as far as I'm aware of. I will be detailing below where to get this and how I installed it below. Keep in mind there might be other ways of installing it, this is just how I did it. 

To start off, you'll want to get your hands on the latest 460 driver here. This is the latest production branch. It will download a .run file which you won't be able to just run as normal and this is where the slightly tricky/risky part comes in so you'll want to follow these directions exactly. I will source where I got this answer below.

You'll want to press the key combination CTRL+ALT+F1 to enter single user mode and login with your credentials.
After this run sudo service lightdm stop to exit the X server that will prevent you from installing the driver.
Enter run level 3 by running sudo init 3
Navigate to the folder you've downloaded the run file into. Typing ls NVIDIA* will make it easier to find the file if that folder happens to have a lot of files. I'd recommend it so you can type it in easier.
You first have to make the file executable with chmod by running chmod +x ./NVIDIA-driver-file.run (Obviously fill in the name of the one you have)
Finally execute the file with sudo ./NVIDIA-driver-file

This can take a minute, the installer that it runs doesn't graphically represent its progress, at least it didn't for me. So now would be a good time to take care of some chores, get a coffee, or just twiddle your thumbs. Whatever you want to do to pass the time.

After this process is done restart the server running sudo service lightdm start.

The source I list says that rebooting is optional, but I'd do it anyways just to be safe, simply because it is a driver update. Also if you ever update your kernel, this process will need to be redone if the 460 driver isn't available already through the GUI driver update tool. source

It should be noted that the GUI will more than likely not represent the correct driver installed, or just say that as manually installed one was applied. To check your driver version, run nvidia-smi in the terminal. You should get a return similar to mine here.
565213466_Screenshotfrom2021-01-0813-47-

After which, you should be good to go, and Warthunder shouldn't crash anymore! If anyone else still runs into a crash after updating to 460, please reply to this post letting me know.

  • Like 1
  • Thanks 1
medal medal

Share this post


Link to post
Share on other sites

Confirmed, over an hour after moving to the 460 driver and no issues ...so far. It would have crashed out at least 3 or 4 times in that period under the Nvidia 450 driver.

Thanks for the assistance

 

....only problem still is I'm still scoring as before :facepalm:


 

Share this post


Link to post
Share on other sites

Did not helped in my case. I still can launch only is windowed mode. It hangs as soon as I switch to fullscreen.

 

System:    Host: ERPU-MI Kernel: 5.4.0-60-generic x86_64 bits: 64 Desktop: Gnome 3.36.4 
           Distro: Ubuntu 20.04.1 LTS (Focal Fossa) 
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Device-2: NVIDIA GP108M [GeForce MX150] driver: nvidia v: 460.32.03 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce MX150/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03 

 

Share this post


Link to post
Share on other sites
7 hours ago, lem8r said:

Did not helped in my case. I still can launch only is windowed mode. It hangs as soon as I switch to fullscreen.

 

System:    Host: ERPU-MI Kernel: 5.4.0-60-generic x86_64 bits: 64 Desktop: Gnome 3.36.4 
           Distro: Ubuntu 20.04.1 LTS (Focal Fossa) 
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Device-2: NVIDIA GP108M [GeForce MX150] driver: nvidia v: 460.32.03 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce MX150/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03 

 


Does it hang with the same error, or something different? I'm not entirely familiar with the GP108 chip but from what I can find they're somewhat low performance so I'm almost wondering if it's getting hitched somehow trying to process the hangar because it is pretty intensive for my machine as well at the moment. 

medal medal

Share this post


Link to post
Share on other sites

Same error.

 

Well, yes it is not that powerful but same notebook on windows can deliver ~40 fps on high settings.

And on Linux I can play it but in windowed mode. So this is not about performance but issues with nvidia driver. I have no issues on desktop with amd gpu.

 

I assigned hotkey to turn current window to fullscreen.

Next I start WT in windowed mode. I can play it for hours without any issues. But as soon as I switch it to fullscreen with a hotkey if freezes with fences timeout.

Share this post


Link to post
Share on other sites

Hello, @lem8r,

 

Could you please upload a .clog file from a session in which you get the crash? Also how are you changing the game window from windowed to fullscreen?

Share this post


Link to post
Share on other sites
5 hours ago, apemax said:

Hello, @lem8r,

 

Could you please upload a .clog file from a session in which you get the crash? Also how are you changing the game window from windowed to fullscreen?

Sure.

 

Gnome has hotkey to switch any window to fullscreen. It has no binding by default so I configured it to be Win+F11.

windowed2fullscreen.clog.zip

Share this post


Link to post
Share on other sites

@lem8r,

 

Right, WT seems to be running on your Intel iGPU, Does starting the launcher with this command help?

 

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia ./launcher

 

That should launch the game on your Nvidia GPU. Could you also please post your full system information?

Share this post


Link to post
Share on other sites

I have discrete GPU selected as default. Wonder how it can launch on integrated Intel.

However here are details and clog

 

inxi -F

 

Spoiler
System:    Host: ERPU-MI Kernel: 5.4.0-60-generic x86_64 bits: 64 Desktop: Gnome 3.36.4 
           Distro: Ubuntu 20.04.1 LTS (Focal Fossa) 
Machine:   Type: Laptop System: Timi product: TM1701 v: N/A serial: 16771/00108368 
           Mobo: Timi model: TM1701 v: MP serial: MMG5S000001178ABP00B8 UEFI: INSYDE v: XMAKB5R0P0906 date: 10/23/2018 
Battery:   ID-1: BAT0 charge: 57.8 Wh condition: 57.8/60.0 Wh (96%) 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP L2 cache: 8192 KiB 
           Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Device-2: NVIDIA GP108M [GeForce MX150] driver: nvidia v: 460.32.03 
           Display: server: X.Org 1.20.9 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce MX150/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.4.0-60-generic 
Network:   Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi 
           IF: wlp3s0 state: up mac: 14:4f:8a:7a:a4:f9 
           IF-ID-1: br-2eb131b0d151 state: down mac: 02:42:09:fe:58:b3 
           IF-ID-2: br-3936a4a958b7 state: down mac: 02:42:45:d7:ca:83 
           IF-ID-3: br-a26e2a69c71b state: down mac: 02:42:6b:80:4f:de 
           IF-ID-4: br-e911ba3d571d state: down mac: 02:42:30:6d:3c:9e 
           IF-ID-5: docker0 state: down mac: 02:42:36:7b:df:fb 
           IF-ID-6: virbr0 state: down mac: 52:54:00:70:74:6e 
           IF-ID-7: virbr0-nic state: down mac: 52:54:00:70:74:6e 
Drives:    Local Storage: total: 238.47 GiB used: 276.27 GiB (115.8%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 500GB size: 465.76 GiB 
           ID-2: /dev/nvme1n1 vendor: Samsung model: MZVLB256HAHQ-00000 size: 238.47 GiB 
Partition: ID-1: / size: 233.24 GiB used: 117.13 GiB (50.2%) fs: ext4 dev: /dev/nvme1n1p2 
           ID-2: /home size: 457.45 GiB used: 159.14 GiB (34.8%) fs: ext4 dev: /dev/nvme0n1 
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A gpu: nvidia temp: 42 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 430 Uptime: 3h 14m Memory: 15.52 GiB used: 4.48 GiB (28.9%) Shell: bash inxi: 3.0.38

 

 

WT launched with

 

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME="nvidia" __VK_LAYER_NV_optimus="NVIDIA_only" ./launcher

windowed2fullscreenNvidia.clog.zip

 

 

 

Edited by lem8r

Share this post


Link to post
Share on other sites

In my case

 

xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x1b8 cap: 0x1, Source Output crtcs: 0 outputs: 0 associated providers: 1 name:NVIDIA-0
Provider 1: id: 0x1df cap: 0x2, Sink Output crtcs: 3 outputs: 4 associated providers: 1 name:modesetting

So I think correct env vars should be 

 

__NV_PRIME_RENDER_OFFLOAD=0 __GLX_VENDOR_LIBRARY_NAME="nvidia" ./launcher

 

ProviderZero.clog.zip

Share this post


Link to post
Share on other sites

@lem8r,

 

Thank you, The client when launched with this command:

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME="nvidia" __VK_LAYER_NV_optimus="NVIDIA_only" ./launcher

Was using your Nvidia MX150, The client when launched with this command:

 

__NV_PRIME_RENDER_OFFLOAD=0 __GLX_VENDOR_LIBRARY_NAME="nvidia" ./launcher

Was using your Intel iGPU. Just so you know. You should get better performance with your Nvidia GPU anyway.

 

Regarding the crashes, So you only get the vkWaitForFences() crash when you switch from windowed to fullscreen? If you launch the game directly in fullscreen on your Nvidia GPU do you get the vkWaitForFences() crash at all? If you launch the game directly in fullscreen on your Intel iGPU do you get the vkWaitForFences() crash at all?

 

Is the setting you use to change the window from windowed to fullscreen the "Toggle fullscreen mode" option in the Gnome Keyboard Shortcuts section?

Share this post


Link to post
Share on other sites

That's interesting. I thought it is enough to choose GPU in nvidia settings.

image.thumb.png.551b8286f1037ae39e5fab09

 

I did couple launches with different GPUs (__NV_PRIME_RENDER_OFFLOAD=0 and 1) and fullscreen vs windowed switched to fullscreen via hotkey modes.

 

I got vkQueueSubmit() when starting directly into fullscreen mode. Hangs on black screen right after launch not depending on GPU.

 

I got vkWaitFotFences() error when starting in windowed mode and switching to fullscreen again not depending on GPU.

 

1 hour ago, apemax said:

Is the setting you use to change the window from windowed to fullscreen the "Toggle fullscreen mode" option in the Gnome Keyboard Shortcuts section?

 

Yes. Gnome settings Shortcuts section.

 

Attached clogs generated when starting directly into fullscreen mode.

intelFullscreen.clog.zip nvidiaFullscreen.clog.zip

Share this post


Link to post
Share on other sites

@lem8r,

 

Right, Thank you.

Share this post


Link to post
Share on other sites

I still have the problems after the 460 nvidia driver upgrade I can run on windowed mode but when I switch to fullscreen I get vkWaitForFences error I tried all the solutions above but still have the problem

Screenshot from 2021-01-15 02-16-01.png

Edited by KayracCc2004
uploaded screenshot

Share this post


Link to post
Share on other sites

Hello @KayracCc2004,

 

Could you please post your full system information?

 

Or:

 

Share this post


Link to post
Share on other sites

System:
  Host: k Kernel: 5.8.0-38-generic x86_64 bits: 64 Desktop: Gnome 3.36.4 
  Distro: Ubuntu 20.04.1 LTS (Focal Fossa) 
Machine:
  Type: Laptop System: Acer product: Aspire E5-571G v: V1.16 
  serial: <superuser/root required> 
  Mobo: Acer model: EA50_HB v: V1.16 serial: <superuser/root required> 
  UEFI: Insyde v: 1.16 date: 09/25/2014 
Battery:
  ID-1: BAT1 charge: 33.0 Wh condition: 33.0/55.9 Wh (59%) 
CPU:
  Topology: Dual Core model: Intel Core i5-4210U bits: 64 type: MT MCP 
  L2 cache: 3072 KiB 
  Speed: 998 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 1036 2: 1038 
  3: 1012 4: 1010 
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel 
  Device-2: NVIDIA GM108M [GeForce 840M] driver: nvidia v: 460.32.03 
  Display: x11 server: X.Org 1.20.9 driver: modesetting,nvidia 
  unloaded: fbdev,nouveau,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: GeForce 840M/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03 
Audio:
  Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel 
  Device-2: Intel 8 Series HD Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k5.8.0-38-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp1s0f1 state: up speed: 100 Mbps duplex: full mac: f0:76:1c:39:dd:20 
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  driver: ath9k 
  IF: wlp2s0 state: up mac: ac:b5:7d:40:2a:44 
  Device-3: Lite-On Atheros AR3012 Bluetooth type: USB driver: btusb 
Drives:
  Local Storage: total: 223.58 GiB used: 138.05 GiB (61.7%) 
  ID-1: /dev/sda vendor: SanDisk model: SSD PLUS 240GB size: 223.58 GiB 
Partition:
  ID-1: / size: 218.57 GiB used: 138.05 GiB (63.2%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 51.0 C mobo: N/A gpu: nvidia temp: 45 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 317 Uptime: 17m Memory: 7.70 GiB used: 2.34 GiB (30.4%) 
  Shell: bash inxi: 3.0.38 

Share this post


Link to post
Share on other sites

@KayracCc2004,

 

Thank you, Could you please upload a .clog file from the same session in which this crash happened?

Share this post


Link to post
Share on other sites

Since I have the same problem and started a thread (maybe at the wrong location) where I added infos from my reasearch via internet, I'm adding these infos here, which might be the better place:
 

I found the same problem in a forum, where someone wants to get clarified
if the threadstarter
has called device.vk.WaitForFences
between calls to
vkResetFences and vkQueueSubmit,
which might cause the problem.

 

Ask Your developers, if there is an edge case like this in the program.


And if so, pls fix it as soon as possible!!!

 

 

 

 

Really bothered by this and restarting the game x-times again and again while loosing loosing points when WT after a  while crashes inside a battle...

Edited by GiffiMarauder

Share this post


Link to post
Share on other sites

@KayracCc2004,

 

Thank you, Could you please switch to the WIP client (The "Use 'Work-in-Progress' client checkbox in launcher) and see if you still get the same error and crash?

Share this post


Link to post
Share on other sites
2 hours ago, apemax said:

@KayracCc2004,

 

Thank you, Could you please switch to the WIP client (The "Use 'Work-in-Progress' client checkbox in launcher) and see if you still get the same error and crash?

 

Solves issue for me (version 2.3.0.74).

 

Thanks!

Share this post


Link to post
Share on other sites

@lem8r,

 

Good to hear, Thank you for letting me know. :salute:

Share this post


Link to post
Share on other sites

@GiffiMarauder,

 

Right, Are you still on the 460.27.04 Nvidia driver? If so could you please update to the 460.32.03 Nvidia driver and see if you still get the same crashing?

Share this post


Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...