Jump to content

I cannot start launcher. It is version 2.30.62., it worked fine , but  i cannot start it , it shows only outline border of the launcher and it is transparent. After some time there is error message.It happens after new upgrade to version 2.30.64. Possible cause could be new Linux firmware or new Nvidia driver (455.45.01). I am using Linux Mint 20, on Acer Aspire 7 intel i5-8300H 2,3 ghz GTX 1050 with 4gb memory , 8 gb ddr4 memory.

Log files are here from today (Saturday):

p3ga2x7ng.zip 2021_01_09_17_53_19_2075.txt p3ga2x7ng.dmp

Edited by WarWolf51
added logs

Share this post


Link to post
Share on other sites

Hello @WarWolf51, @Shirethrone,

 

Could you both please upload your latest launcher log file? They are located here: /WarThunder/.gaijin_launcher_logs

 

 

Share this post


Link to post
Share on other sites

Thanks for the reply. I have attached both files from the launcher.

The issue seems to arise from libc.so.6. When starting aces directly I get two errors: the first gives 81110007 as an error code (The usual solution doesn't seem to work because it also doesn't work on a clean new install). The second error also references libc.so.6 but doesn't give an error code.

2021_01_08_23_30_28_8282.txt 2021_01_08_23_30_28_8282.fatal.txt

medal medal medal medal medal

Share this post


Link to post
Share on other sites

I upgraded Linux Mint 20 to Linux Mint 20.1, kernel and Nvidia driver also upgraded but problem stays. Dont tell me that launcher uses Flash , that could be a problem.

Share this post


Link to post
Share on other sites

@Shirethrone,

 

Thank you, The issue you have has already been reported and is known however could you please post your full system information so I can update the report?

 

Or:

 

 

@WarWolf51,

 

The launcher uses Vulkan, Not Flash. ;) Do you have a laptop? As from the log you uploaded the game client is trying to start on your Intel iGPU. Does starting the launcher using this command in your main "WarThunder" directory work?

 

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia ./launcher

Share this post


Link to post
Share on other sites

Here are 2 pictures showing what happened . On second image, there is a message what happened after I executed above command. (also visible on first image).On first image is output from inxi command.

And yes, I have a laptop. And I send error report directly from launcher.

Slika zaslona 2021-01-14 15-53-00.png

Slika zaslona 2021-01-14 15-46-05.png

Edited by WarWolf51

Share this post


Link to post
Share on other sites

@WarWolf51,

 

Thank you, Looks like it's still trying to launch on your Intel iGPU, Could you please try this command to launcher the launcher and see if it works?

 

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia __VK_LAYER_NV_optimus=NVIDIA_only ./launcher

 

Share this post


Link to post
Share on other sites

@WarWolf51,

 

Right, Could you please open nvidia-settings and have a look to see if you have a "Prime Profiles" tab? If so could you please post a screenshot of it?

Share this post


Link to post
Share on other sites

@WarWolf51,

 

Right, Could you please try this command and see if it works?

 

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/nvidia_icd.json ./launcher

 

  • Like 1

Share this post


Link to post
Share on other sites

@WarWolf51,

 

Right, Could you please post the output of this command?

 

xrandr --listproviders

 

Share this post


Link to post
Share on other sites

@WarWolf51,

 

Thank you, Could you please try this command and see if it works?

 

__NV_PRIME_RENDER_OFFLOAD=0 __GLX_VENDOR_LIBRARY_NAME=nvidia VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/nvidia_icd.json ./launcher

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Finnally! Laucher started checking files! Thank you very much apemax! I hope there are be no more problems. 

But i will need to enter this command everytime I play War Thunder.

Edited by WarWolf51

Share this post


Link to post
Share on other sites

@WarWolf51,

 

Well thats good to hear, Do other games (Vulkan games specifically) start on your Nvidia GPU fine when you just launch them normally?

Share this post


Link to post
Share on other sites

Other games with native Linux start normaly . War Thunder is specific. It isnt installed, just unpack and play.Windows games  they run fine or dont run at all.

Share this post


Link to post
Share on other sites

I have same launcher error issue as topic starter (this time I have problem with my laptop)
The game is installed directly from website (no Steam) and version is 2.3.0.85
Same behavior at startup - it shows only outline border of the launcher and it is transparent and it ends with this error.

Screenshot_20210204_125031.thumb.png.b92

 

35d3aa46-ec81-28bf-7e27449a-0a172df5.dmp

2021_02_04_12_49_21_15009.txt

2021_02_04_12_49_21_15023.txt

 

Trying startup with command

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia ./launcher

also ends with error.

 

Startup with command

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia __VK_LAYER_NV_optimus=NVIDIA_only ./launcher

is success.


In all cases it has warning about intel-mesa, but if game starts, it works ok.

Quote

INTEL-MESA: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0

 

[email protected]:~$ inxi -F
System:    Host: Ordi-laptop Kernel: 5.4.0-64-generic x86_64 bits: 64 Desktop: KDE Plasma 5.20.5 Distro: KDE neon 20.04 5.20 
Machine:   Type: Laptop System: Notebook product: N85_N87,HJ,HJ1,HK1 v: N/A serial: <superuser/root required> 
           Mobo: Notebook model: N85_N87,HJ,HJ1,HK1 serial: <superuser/root required> UEFI: American Megatrends v: 1.05.01 
           date: 12/13/2016 
Battery:   ID-1: BAT0 charge: 43.9 Wh condition: 43.9/59.9 Wh (73%) 
CPU:       Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP L2 cache: 6144 KiB 
           Speed: 800 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: Intel HD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: nvidia v: 460.39 
           Display: x11 server: X.Org 1.20.9 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 460.39 
Audio:     Device-1: Intel CM238 HD Audio driver: snd_hda_intel 
           Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.4.0-64-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: enp3s0f1 state: down mac: 80:fa:5b:41:02:fe 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi 
           IF: wlp4s0 state: up mac: 00:28:f8:38:0d:33 
Drives:    Local Storage: total: 1.36 TiB used: 576.62 GiB (41.3%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 500GB size: 465.76 GiB 
           ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB 
Partition: ID-1: / size: 46.68 GiB used: 15.97 GiB (34.2%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /home size: 147.89 GiB used: 96.86 GiB (65.5%) fs: ext4 dev: /dev/nvme0n1p7 
           ID-3: swap-1 size: 15.26 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p6 
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A gpu: nvidia temp: 50 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 269 Uptime: 1h 59m Memory: 15.40 GiB used: 2.39 GiB (15.5%) Shell: bash inxi: 3.0.38

 

Edited by MetsaVend88
forgot add output of inxi -F

Share this post


Link to post
Share on other sites

To add to this topic:
I have the same issue as the topic starter, and the previous post by MetsaVend88

 

Indeed the following does not work

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia ./launcher

 

And this command works!

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia __VK_LAYER_NV_optimus=NVIDIA_only ./launcher

 

I also get an INTEL-MESA warning, but mine reads the following:

MESA-INTEL: warning: Ivy Bridge Vulkan support is incomplete

 

I don't really have much else to add, except to show my computer configuration to maybe help narrow the problem down.

$ inxi -F
System:    Host: laptop-n56vb Kernel: 5.10.7-3-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.20.5 Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: N56VB v: 1.0 serial: <superuser required> 
           Mobo: ASUSTeK model: N56VB v: 1.0 serial: <superuser required> UEFI: American Megatrends v: N56VB.202 
           date: 01/21/2013 
Battery:   ID-1: BAT0 charge: 6.5 Wh condition: 9.7/57.7 Wh (17%) 
CPU:       Info: Quad Core model: Intel Core i7-3630QM bits: 64 type: MT MCP L2 cache: 6 MiB 
           Speed: 2213 MHz min/max: 1200/3400 MHz Core speeds (MHz): 1: 2213 2: 2340 3: 2620 4: 2519 5: 2174 6: 2455 7: 2435 
           8: 2517 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel 
           Device-2: NVIDIA GK107M [GeForce GT 740M] driver: nvidia v: 460.32.03 
           Device-3: Sunplus Innovation Asus Webcam type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.10 driver: loaded: modesetting,nvidia resolution: 1: 1920x1080~60Hz 
           2: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GT 740M/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel 
           Device-2: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo 
           Device-3: Generalplus USB Audio Device type: USB driver: hid-generic,snd-usb-audio,usbhid 
           Device-4: Corsair VOID Wireless Gaming Dongle type: USB driver: hid-generic,snd-usb-audio,usbhid 
           Sound Server: ALSA v: k5.10.7-3-MANJARO 
Network:   Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k 
           IF: wlp3s0 state: down mac: 4e:25:c9:fe:08:f4 
           Device-2: Qualcomm Atheros AR8161 Gigabit Ethernet driver: alx 
           IF: enp4s0 state: down mac: 60:a4:4c:71:91:86 
           Device-3: IMC Networks Atheros AR3012 Bluetooth 4.0 Adapter type: USB driver: btusb 
           Device-4: Xiaomi 100Mbps Network Card Adapter type: USB driver: cdc_ether 
           IF: enp0s20u1u1u3c2 state: unknown speed: N/A duplex: N/A mac: 9c:eb:e8:61:4e:26 
Drives:    Local Storage: total: 810.43 GiB used: 350.23 GiB (43.2%) 
           ID-1: /dev/sda vendor: Crucial model: CT750MX300SSD1 size: 698.64 GiB 
           ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 120GB size: 111.79 GiB 
Partition: ID-1: / size: 677.72 GiB used: 350.17 GiB (51.7%) fs: ext4 dev: /dev/sda2 
           ID-2: /boot/efi size: 299.4 MiB used: 24.3 MiB (8.1%) fs: vfat dev: /dev/sda1 
Swap:      ID-1: swap-1 type: partition size: 8.8 GiB used: 42.5 MiB (0.5%) dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 71.0 C mobo: N/A gpu: nvidia temp: 60 C 
           Fan Speeds (RPM): cpu: 2800 
Info:      Processes: 300 Uptime: 2h 35m Memory: 7.66 GiB used: 3.62 GiB (47.2%) Shell: Bash inxi: 3.2.02

 

Judging by the previous system overviews, it sure seems to be related to having an integrated and dedicated graphics card.

I would like to point out that I am not using my integrated graphics card. Everything runs on my Nvidia graphics card.

No bumblebee, no optimus. Just the pure Nvidia driver.

Share this post


Link to post
Share on other sites

Problem is technically solved, only entering that command everytime i start WT is a bit inconvinient. I copied command that works for me in a text file and I copy-paste it in terminal every time I play WT.

Game isnt installed so i need to browse personal map in order to play WT anyway.

Share this post


Link to post
Share on other sites

Write it in file (named f.e. wt), make it bash script (#!/bin/bash in first line), put it in /usr/local/bin, make it executable (chmod +x /usr/local/bin/wt) an then you can run it simply: wt.

Edited by chmooreck

Share this post


Link to post
Share on other sites

@WarWolf51, @MetsaVend88, @Chris54555,

 

Could you all please upload a launcher log file from when you start the launcher normally, So using this command:

 

./launcher

 

And also upload a .clog file from when you start the same executable directly, So this command in your main "WarThunder" directory:

 

./linux64/aces

 

Also, If you haven't already could you please post your full system information as per the reporting guidelines?

 

 

Also, @WarWolf51,

 

You can also create a "bin" directory in your home directory, Then put the bash script in there, Mint should already have that directory in your PATH.

Share this post


Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...