Jump to content

Actual Warthunder version crashes randomly with following example error, all software is up to date:

 

device.vk.WaitForFences(device.get(), 1, ptr(fence), VK_TRUE, UNIT64_MAX) failed
Call stack ( 11 frames):
./linux64/aces() [0x128cfbb]
./linux64/aces() [0x28f9ef4]
./linux64/aces() [0x292ad40]
./linux64/aces() [0x2920ab0]
./linux64/aces() [0x2924136]
./linux64/aces() [0x293bbf5]
./linux64/aces() [0x12884bb]
./linux64/aces() [0x12885e9]
./lib64/libpthread.so0(+0x84f9) [0x7fe2a6c744f9]
./lib64/libc.so6(clone+0x3f) [0x7fe2a571dfbf]
[(nil)]

 

 

Hardware: Lenovo ideapad Y910-17ISK

inxi -v 1:

System:    Host: Blah.Blah Kernel: 5.3.18-lp152.57-default x86_64 bits: 64 Desktop: KDE Plasma 5.18.6
           Distro: openSUSE Leap 15.2

CPU:       Quad Core: Intel Core i7-6820HK type: MT MCP speed: 900 MHz min/max: 800/3600 MHz
Graphics:  Device-1: NVIDIA GP104BM [GeForce GTX 1070 Mobile] driver: nvidia v: 460.27.04
           Device-2: Acer type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.3 driver: nvidia unloaded: modesetting resolution: 1920x1080~75Hz
           OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 460.27.04
Drives:    Local Storage: total: 1.38 TiB used: 57.50 GiB (4.1%)
Info:      Processes: 268 Uptime: 1h 31m Memory: 15.57 GiB used: 1.70 GiB (10.9%) Shell: bash inxi: 3.1.00

 

 

Any ideas how to fix that?

Really annoying in the middle of  a battle...

04540235-db90-6e1d-12d1dfee-7ea9dba9.dmp 2021_01_03_20_23_05__5402.clog

Edited by GiffiMarauder
additional infos

Share this post


Link to post
Share on other sites

I've been having the same exact same problem as well as a lot of other people. It was originally reported in the Linux bug reporting thread, and has since been moved to Already Reported & Solved Issues here 

That being said, I don't know exactly what that means considering I haven't heard a word about it being fixed. Been trying to search for the solution too.

So far I've tried a huge array of different graphical options, different drivers, fullscreen/windowed. I even tried Proton to see if maybe I could force the game to run in DX mode through a layer and just take the performance hit, but that was just DOA as the launcher wouldn't even display properly.

Anyways, in that post you can find a bunch of people all complaining about the same thing. Would be really good to hear something about the bug as it makes Warthunder essentially unplayable on Linux machines affected by it.

Not trying to be blunt, but it would be good if when they moved it over to that thread, they could explain their reasoning as to why. Such as "The devs are working on it", or "We found a fix in X thread". Kinda creates a feeling of being brushed aside IMO

Attached is the latest .clog file as well as an INXI for complete system info. For some reason though my latest .dmp file is the one I already posted in the above mentioned thread.

2021_01_04_22_57_25__48066.clog

inxi.txt

Edited by ConspicuousFox
medal medal

Share this post


Link to post
Share on other sites

Today again and the days before too inside a running battle and team members think You are leaving them alone, xxxx!!!!


FIX it or Move LINUX away from your OS list if you only employ incompetent developers. This way we won't waste our time with this game!!!

 

 

 

edited:

After searching the internet I found the same problem in a forum, where someone wants to get clearified if the threadstarter has called this function between calls to vkResetFences and vkQueueSubmit, which might cause the problem.

Ask Your developers, if there is an edge case like this in the program.
And if so, pls fix it as soon as possible!!!

 Really bothered by this and restarting tzhe game x-times again and again while loosing loosing points when WT after a  while crashes inside a battle...
 
 

Edited by GiffiMarauder
new information

Share this post


Link to post
Share on other sites
  • 2 weeks later...

@GiffiMarauder,

 

Could you please switch to the WIP client (The "Use 'Work-in-Progress' client checkbox in launcher) and see if you still get the same error and crash?

Share this post


Link to post
Share on other sites

There is another thread about the crashes where I had added the same infos as here.
From that one I'm running all the time on the WIP-Client since your first suggestion and it has become worser today since  about 0:50 this day, about 10 crashes in the battle...

 

Share this post


Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...